Invite doesn't send emails?

Hi,

Invite isn't sending invites.

I get a "Invite(s) sent." message, but the invites don't arrive. I haven't changed any of the message content.

Do I need to set something else up?

I did have wp-mail-smtp installed, but have disabled it - no difference.

thanks in advance, Ross

  • aecnu
    • WP Unicorn

    Greetings Ross,

    Thank you for bringing this item to our attention.

    After checking into this I am unable to replicate any issues with this plugin on my production servers.

    With that in mind I am wondering if the host is possibly blocking the use of WordPress mail feature? I believe php mail () function?

    Can you confirm this by any chance?

    You mentioned that I did have wp-mail-smtp installed, but have disabled it - no difference.

    Was there a reason why you chose to use this in the first place?

    Please advise.

    Cheers, Joe

  • Ross
    • Flash Drive

    Ok, I've got it working with wp-mail-smtp using Google Apps.

    Question: When I invite from a blog e.g. subsite.mysite.com, it invites the user to register on mysite.com

    Is there a way for people I invite to subsite.mysite.com get directed to register on subsite.mysite.com - or does this happen later in the process anyway?

    thanks, Ross

  • aecnu
    • WP Unicorn

    Greetings Ross,

    Happy to see that you got the email issue resolved and to answer your question:

    Is there a way for people I invite to subsite.mysite.com get directed to register on subsite.mysite.com - or does this happen later in the process anyway?

    Not without intervening with some custom code of some sort and not for WordPress out of the box but I have attached below a plugin from my personal archive that may still get the job done for you and let me know how it goes if you indeed try it out.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.