Invoice Data Fields are Incomplete

Hello,

The invoice date on my memberships are not displaying properly in my 'Billing' page and on the invoices.

See the attached screenshot for more information.

The invoices are also displaying very oddly (also shown in attached screenshot)

  • Tyler Postle
    • CGO

    Hey again Daniel,

    It looks like your date format in WordPress might be set to “Custom: ” with only the day.

    Go to:

    Settings > General. and scroll down to “Date Format”. As seen in my screen. Select the one you prefer and that should fix the way the date is displayed on the invoices as well.

    The invoices are also displaying very oddly (also shown in attached screenshot)

    This is likely due to a conflict with your theme. Can you try temporarily swapping to the default 2015 theme and checking if it’s still displaying oddly for you?

    Look forward to hearing back.

    All the best,

    Tyler

  • Sajid
    • DEV MAN’s Sidekick

    Hi Daniel,

    Hope you are doing good today :slight_smile:

    Thanks for sharing the screenshot and granting support staff access. I can see that the Date is showing correctly on your invoice (see screenshot).

    Regarding the issue with design, try adding following code in style.css file of your child theme or using Simple Custom CSS plugin.

    .single-ms_invoice div#sidebar {
    display: none;
    }

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi Daniel,

    Hope you are doing good today :slight_smile:

    Thant CSS code suppose to hide the search and archive links (sidebar) under it. Does the sidebar still there under the table ?

    If yes and that is what you wanted to do then try using the below code (note the !important).

    .single-ms_invoice div#sidebar {
    display: none !important;
    }

    Let me know how it went and have a nice day :slight_smile:

    Cheers, Sajid

  • Daniel
    • The Incredible Code Injector

    Hi Sajid,

    I’ve copied this into my CSS theme editor on Upfront, but there is no change to the display of the invoice yet.

    /* The following code is for the invoice display*/
    .single-ms_invoice div#sidebar {
    display: none !important;
    }

  • Sajid
    • DEV MAN’s Sidekick

    Hi Daniel,

    Hope you are doing good today :slight_smile:

    Could you please enable support staff access so I can take a closer look ? I will add/update the CSS code myself in upfront.

    You can grant access from WPMU DEV -> Support -> Support Access -> Grant Access or see this manual.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid
    • DEV MAN’s Sidekick

    Hi Daniel,

    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. You are right, in upfront this code has no impact on this page. I saw you have installed & active Simple Custom CSS plugin on your website. I added the custom code in Appearance -> Custom CSS and it worked just fine.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Daniel
    • The Incredible Code Injector

    Thank you, Sajid!

    Is there a way to add a logo and/or a print button to the invoice?

    I’d also like to center it in the window and bring it down from the very top of the page.

    Say, center align the content and 50px margin above the invoice.

    Is that possible?

  • Sajid
    • DEV MAN’s Sidekick

    Hi Daniel,

    We can not add button I am afraid but I have styled a little bit and also added the icon on top of the screen.

    Feel free to replace the URL with your own image and change the height width according to your requirements in following code (its already in Appearance -> Custom CSS).

    .ms-invoice-details.ms-status-paid:before {
    content: "";
    width: 150px;
    height: 100px;
    top: 75px;
    background: url(//sivar.staging.wpengine.com/wp-content/uploads/2016/04/LogoThumb-50x60-8849.png);
    background-color: red;
    display: block;
    margin: 0px auto;
    margin-top: 50px;
    background-repeat: no-repeat;
    background-size: contain;
    background-position: center;
    }

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.