Ip address does not show in site

I set an IP address in Network Admin-Settings-Domain Admin. On our sites the IP address does not show and it says admin has not set up an IP address I believe because of this message I cannot add a domain to a site.

  • Timothy
    • Chief Pigeon

    Hey there.

    So all the sunrise.php is setup?

    And you put the constant in the right place within your wp-config.php file?

    Can I see a screenshot of the network admin and your normal site admin where the domain mapping is?

    Maybe try to deactivate and reactivate?

    If it’s not working then try downloading a fresh set of files, remove the old ones and upload the new one replacing them.

    If that doesn’t work then I might need to take another look but often not being able to add a domain name is an issue with where you put the constant in your wp-config.

    Thanks.

  • Timothy
    • Chief Pigeon

    Hey there.

    Did you also try:

    Maybe try to deactivate and reactivate?

    If it’s not working then try downloading a fresh set of files, remove the old ones and upload the new one replacing them.

    If so then I’d need to take a look.

    Can you please send in:

    – Mark to my attention

    – Link back to this thread

    – Include admin/network access

    – PHPMyAdmin or similar (usually in cPanel)

    – Include FTP

    https://premium.wpmudev.org/contact/

    I’d need to look in the database.

    Thanks.

  • coburnenterprises
    • Site Builder, Child of Zeus

    @timothy – did you figure this out? I am having the same issue on a new install of a domain and the domain mapping tool. I have gone through the files, the config etc and we are still getting the problem that on the user level (the sub site) it says that we haven’t configured the IP in network settings.

  • Timothy
    • Chief Pigeon

    Hey there.

    It seems you were missing a row in your _sitemeta table, this was for the IP address.

    I’m not sure why it wasn’t added, but I just started testing now and it seems that it neither adds nor updates the IP address. So this is being marked as a bug.

    As a real quick solution if the row “map_ipaddress” doesn’t exist then use this:

    INSERT INTO 'DATABASE-NAME'.'WP-PREFIX_sitemeta' ('meta_id', 'site_id', 'meta_key', 'meta_value') VALUES (NULL, '1', 'map_ipaddress', 'YOUR-IP-ADDRESS');

    If it does, then you can either remove and use that above or update with this:

    UPDATE  'DATABASE-NAME'.'WP-PREFIX_sitemeta' SET  'meta_value' =  'YOUR-IP-ADDRESS' WHERE  'cpn_sitemeta'.'meta_id' =UNIQUE_META_ID;

    Things to change in the SQL:

    YOUR-IP-ADDRESS – Your IP address

    UNIQUE_META_ID – The unique Meta ID

    WP-PREFIX – The prefix set for your WordPress install.

    DATABASE-NAME – Database name

    Take care.

  • Josh
    • Flash Drive

    I’ve also been dealing with this problem for several days. The plugin worked perfectly on a previous installation. But, after deploying a fresh install of WP I’ve experienced the “IP not set” error along with an inability to map any domains. The database row fix did populate the IP address to my blogs, but I’m still unable to add any mapped domains.

  • Josh
    • Flash Drive

    Ok – by combining the database fix listed here with a database fix listed in this thread I was able to correct the problem.

    The combined fix included these two issues:

    The database table “wp_domain_mapping” had been created as “wp_domain_map” and the row “map_ipaddress” did not exist at all.

    I’ve posted in both threads for the benefit of other users who encounter this problem. As I mentioned in the other thread, I’m not sure what’s triggering this anomaly with certain users, but I’d be happy to assist with debugging.

  • Timothy
    • Chief Pigeon

    Hey all.

    We now have an update available, please try that.

    Fixed IP

    ADDRESS NOT SET reporting bug

    Added extra checks in domain mapping options to check if dm table is created and

    if not attempt to recreate or display the required SQL if not possible.

    Updated check for DM_COMPATIBILITY to allow it to be set to No rather than need

    to be commented out.

    *Note* sunrise.php will need to be updated

    Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.