Is a plugin causing this "Argument#1 error?

This really has me baffled...

I saw this error pop up in this thread as well..

https://premium.wpmudev.org/forums/topic/buddypress-themes/page/2

But don't seem to find the solution.

I'm running buddypress 1.0.3 and wpmu 2.8.4 and get this as soon as I register a new blog...

[function.array-merge]: Argument #1 is not an array in /home/thatmlmb/public_html/wp-content/plugins/buddypress/bp-xprofile/bp-xprofile-signup.php on line 261

The code on line 261 is

$bp_blog_signup_meta = array_merge( $bp_meta, $blog_meta );

Any ideas?

Thanks,

George