Is domain mapping not working because my WPMU is not setup as subdomain

We've been at this for three days now. Trying to get the Domain Mapping plugin to work with my site and sub-sites.

To recap, Domain Mapping has been setup properly, You guys have observed settings via WPMU dashboard.

I followed everything in the "usage" instructions, but its not working. I went into my multisite primary site's cpanel and tried to set up an A record, after that did work so I tried a CName. After that didn't work I went into WHM account set up a DNS Zone and that didn't work.

POSSIBLE CONFLICT!!!!
I did notice that my site is setup to create subdirectories (sitemerce.com/vivamexicojc), and my host "A" and CNames creates subdomains (vivamexicojc.sitemerce.com) not sure if this is the issue of why it's not mapping.

I turned off domain mapping for that subdirectory until you help me get it resolved. Please let me know what kind of access you'll need to help me figure this out. Thanks.

Main site is: sitemerce.com
Subdomain is: sitemerce.com/vivamexicojc.com
Client's URL is: vivamexicojc.com

  • Mrinal
    • Site Builder, Child of Zeus

    Hey @Rafael,

    Thanks for your thread in our forum.

    Yes,, instead of sub directories you need to use sub domain.

    BTW, are you running your primary site on dedicated IP? Dedicated IP is the prerequisite to Domain Mapping plugin.

    Let me know the update from, Cheers!

  • Rafael
    • Flash Drive

    Yes. I'm running on a dedicated ip address on a vps server. So now the big questions are:
    1)- Can I change my current wordpress sub-directory install into a subdomain
    2)- How do I change a fresh wordpress install from a subdirectory to a subdomain. Note: I used Softaculous one-click install left the dir field blank, selected multisite checkbox, but i noticed that the wp-config.php file still had the subdomain as false. Could be a bug in the one-click-install. But the big question is HOW DO I SET UP WPMU AS A SUBDOMAIN. THANKS.

  • Timothy Bowers
    • Chief Pigeon

    Hey there.

    The issue is the IP address:

    8.29.138.114

    If you load this in your browser you see your default cPanel page, the DocumentRoot must be set to your WordPress install. Most of the time this is /public_html/ and WordPress must be installed in that root.

    Without that any sites that are sent to the IP don't see the WP site and can't be mapped.

    https://premium.wpmudev.org/project/domain-mapping/#usage

    Dedicated IP: For using A Record setups, you need to ensure you have a dedicated IP. This IP would fall onto your multisite setup. i.e. when you enter the IP you see your multisite. This is known as the DocumentRoot for the IP, your host will be able to sort this quickly and easily.

    Your host should be able to fix this easily and quickly, you can't just do it WordPress.

    1. It's possible, you need to alter your htaccess and wp-config.php file.

    You will then need to check the site paths in the DB and change those so that the path is correct.

    If you only have a few sites it's pretty quick and easy to do. You could do a DB dump, find and replace, and reupload it.

    2. You can see what the files should be for sub domains here:

    http://codex.wordpress.org/Create_A_Network

    http://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite

    Domain mapping will work with both types of Multisite.

    Hope this helps, let us know if you have any further questions.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.