is it possible that informations from the subsites

Hello,

is it possible that informations from the subsites are synchronized with informations from the mastersite? When I change the password on the subsite I want it also changed on the mastersite.

Currently on my site it is only possible to change informations on the mastersite. subsite changes will not be synchronized to the mastersite. Is this a bug or is it this not possible with the plugin? On the description page it looks like that the synchronization works in both ways...

I found another error: the user roles are not synchronized when the table prefix of the wordpress are not the same. I had do rename the tables.

Best Regards, David

  • Michael Bissett

    Hey @David, hope you're doing well today!

    is it possible that informations from the subsites are synchronized with informations from the mastersite? When I change the password on the subsite I want it also changed on the mastersite.

    Currently on my site it is only possible to change informations on the mastersite. subsite changes will not be synchronized to the mastersite. Is this a bug or is it this not possible with the plugin?

    It's a one way sync presently, from the master site to a slave site (or several slave sites, if you have multiple sites connected to the master site).

    I found another error: the user roles are not synchronized when the table prefix of the wordpress are not the same. I had do rename the tables.

    Was this for all of your users, or did this only come up for certain users? I had this come up for a few users on my test install (which had a different table prefix than the master site did).

    And what lead to the conclusion that it was due to the table prefixes?

    Please advise,
    Michael

    • David

      It's a one way sync presently, from the master site to a slave site (or several slave sites, if you have multiple sites connected to the master site).

      And there is no way to sync data from the slave site to the master site? This would be a essential feature. This should be described on the product page.

      Is there a hack or trick for the plugin to sync the slave sites?

      Was this for all of your users, or did this only come up for certain users? I had this come up for a few users on my test install (which had a different table prefix than the master site did).

      And what lead to the conclusion that it was due to the table prefixes?

      The role is defined at the usermeta table. The meta key is "tableprefix_capabilities". When you have the prefix wp1 and wp2 you have in the usermeta table for every user "wp1_capabilities" and "wp2_capabilities".

      I have renamed the prefix with the plugin DB Prefix Change to sync the roles...

  • Michael Bissett

    Hey @David,

    And there is no way to sync data from the slave site to the master site? This would be a essential feature. This should be described on the product page.

    Actually, the sales page does have this to say:

    Create and manage user accounts in one place that can be used on any connected site–without Multisite.

    It would imply that user accounts created & managed in the "one place" (that being the Master site here) would be synced over to other sites (that being the Slave sites).

    However, that being said, having the ability to do a two way sync would be a handy feature (though from what I recall, this would be a complex task to carry out, something that would require more than a quick hack/trick).

    I would want to open a feature request thread for this, so that it's more visible here:

    https://premium.wpmudev.org/forums/forum/feature-suggestions#question

    The role is defined at the usermeta table. The meta key is "tableprefix_capabilities". When you have the prefix wp1 and wp2 you have in the usermeta table for every user "wp1_capabilities" and "wp2_capabilities".

    I have renamed the prefix with the plugin DB Prefix Change to sync the roles...

    Hmm... odd, I'm not seeing that the meta keys are any different here on my test site, seems like I might've run into something different what you're running into.

    Regarding your master & slave sites... what if you were to try disabling all of the plugins, and switching to a default theme, does that make a difference here, or does the same behavior take place?

    Please advise,
    Michael