Is the pro version and Igetting logged out of WP SMUSH PRO?

Hello there

I am still getting logged out of WP SMUSH PRO?
OR
Why show a message when I login dasboard?
I have attached some images file you can check.
Please fix these issues asap.

Thanks

    Rupok

    Hi Kemal,

    So sorry to hear the inconvenience you are having. We had a server issue yesterday which caused this same issue to users but that issue was fixed 14 hours ago and all users who reported this issue, got it resolved. I'm really wondering why this is still showing for you.

    As a quick troubleshooting step, can you please try resetting your API Key? You can reset your API key by going to this page: https://premium.wpmudev.org/hub/account/

    On that page, please scroll down to "API Key" box and click the "RESET API KEY" button. After that, try to login to your WPMU DEV Dashboard and please let us know what happens.

    If this doesn't resolve your issue, we will be glad to investigate further.

    Have a nice day. Cheers!
    Rupok

    Mahlamusa

    Hello Kemal,

    We would like to investigate this further and help you resolve the error. Would you please kindly grant us access to your site so we can have a closer look and try to solve the problem We will let you know what the issue was.

    Please follow this guide on how to grant staff access to your site: https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    After we receive access, a staff member will have a look at your install and investigate the issue further and will let you know about the solution.

    Thanks you for contacting us and we appreciate your patience while we investigate this issue.

    Sincerely,
    Mahlamusa

    Rupok

    Hi Kemal,

    Thanks for granting Support Access. I checked it and it's working. I've pinged our SLS guy regarding this. I believe, he will come up with his valuable feedback on this very soon. We will update you as soon as we get anything from him.

    Please keep in mind, our SLS people work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a feedback.

    I'll appreciate your patience.

    Have a nice day. Cheers!
    Rupok

    Mahlamusa

    Hi Kemal,

    I have looked into your setup and during my investigation I had to delete the plugin and install it again. During the process I found that some files were left behind and I have to remove them via FTP.

    Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Lindeni Mahlalela
    - FTP log-in details (hostname, username & password), if you are not sure about your FTP login details then provide cPanel credentials and I will take it from there.
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Keep the staff access active on your website as you have granted access

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Once you have provided this information, I will further investigate and work towards solving the issue on your website.

    We really appreciate your patience while we solve this issue.

    Cheers,
    Mahlamusa

    Mahlamusa

    Hi Kemal,

    Thank you for sending in the required information.

    I have logged in and cleaned the remaining files left while deleting the old plugin. I have installed a fresh copy of the plugin for you and have checked and tested. It works fine.

    The only issue I noticed that may result in things not completing as required is that there your website seems to have high memory usage even if the WP Smush Pro plugin is not running. Your website's memory limit is usually much greater than 85% usage which is very high and may result in some actions stopping unexpectedly.

    Also, there is a message that says you need to keep the page active to make sure the process completes, depending on your setup and usually internet connection problems, WordPress itself can automatically log you out if your internet connection has changed. As a result you will be logged out of your website, not by WP Smush but by WordPress itself.

    With regards to the messages you see on the screenshots you attached, you should not see them again. If you do, let us know, we are always happy to investigate.

    If you are still having any more problems regarding getting logged out of your website, then I suggest you follow this guide https://premium.wpmudev.org/blog/how-to-extend-the-auto-logout-period-in-wordpress/ or this one https://whatswp.com/fix-wordpress-auto-logging-out/

    If you have any more problems, please let us know.

    We appreciate you patience so far.

    Cheers,
    Mahlamusa

    Kemal

    Mahlamusa

    Its frustrating that your WP SMUSH PRO keeps logging me out, its clear after numerous attempts you guys can't solve this issue. Its frustrating to have a service delay things and not do what it says it will do ... I am pleading last time to solve this issue or its the last time I will use your services. You have the technical staff who should understand how to resolve this issue. I am granted you access to the site again.

    Forgive me for my harsh email but its frustrating to always get logged out.

    Kemal

    Mahlamusa

    Hi Kemal,

    I am very sorry for the inconvenience you are having at the moment.

    I have accessed your WordPress admin and noticed that you get logged out of the WPMUDEV Dashboard. I suggest you deactivate, delete and reinstall and activate the WPMU DEV dashboard plugin.

    Once you have reinstalled please click on "WPMU DEV" link on the left side menu and if you are presented with a login screen, please login with the credentials you use to login at premium.wpmudev.org.

    After you have done that, please verify if the logout issue persists or not. The pro version problem showing trial messages should disappear once you have successfully logged in to the dashboard again.

    Please let me know if you are having any more problems.

    Thank you for your patience so far.

    Enjoy your day further.

    Cheers,
    Mahlamusa

    Kemal

    Mahlamusa,

    Its now working like always, but after certain amount of compressing it does the same issue again. I have compressed the same images so many times. It restarts again and then it compresses images I have already compressed many time before ... I really hope this works.

    plus, check on your end why when I am adding a new listing and uploading images it takes forever when your plugin is on and if I turn off your plugin it goes quickly. I know you are compressing images, but property owner do not have the patience to wait this long.

    please, check and let me know

    Mahlamusa

    Hi,

    I am glad it is now working and hopes it continues to work as it should.

    In order for us to help you further we need you to grant staff access to your dashboard, However, I noticed staff access is revoked probably because of the reinstall of the dashboard plugin. Please follow this guide to grant staff access https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/.

    Smush Pro determines if pictures need to be compressed before it attempts to compress them, it will not compress the same ones over and over. You can verify this by looking at the total number of images it says it will optimize, it will say it compressed xx/xx the number of compressed will always increase after each run.

    I think the issue regarding the long processing when installing adding a new listing is because smush pro is set to auto smush new images and in that case if it finds there is a lot of images to be smushed, then it will attempt to smush them all first. So lets make sure all the current images are optimized and then try to add a new listing and see if it processes for a long time again. If that happens again then we will investigate that as another issue.

    You should also note that WordPress itself can log you out of the dashboard if you were not active for some time. Most of the time this is WordPress itself or a security plugin installed on your site that forces logout due to inactivity. It is possible that it is WordPress logging you out, I have had this before on a site without the Smush Pro Plugin installed in it.

    I hope to resolve this soon.

    Cheers,
    Mahlamusa

    Nithin

    Hi Kemal,

    Hope you are doing good today.

    I bulked smushed your image, under Media > WP Smush, and it smushed over 250 images, I stopped smushing, since you have more than 77367+ images remaining. Could you please continue with smushing, and see whether you are noticing any anomalies.

    Once the images are smushed, the plugin will start smushing the remaining images in the Media Library, and the plugin cannot re-smush an image multiple times, because once smushed the images are optimized at it's optimal quality.

    I checked the images before, and after smushing, and they seems to work fine. I have enabled debug mode in your system, by editing wp-config.php file located in your root directory, and changed the following line: define(‘WP_DEBUG’, false);. To:

    define('WP_DEBUG', true);

    And, in order to enable the error logging to a file on the server I added the following lines to wp-config.php

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Would recommend you try Bulk Smush, and make sure to keep the page open, until it completes bulk smush. Once done, if still notice any issues, or any anomalies, related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    If bulk smush doesn't complete, or doesn't perform smoothly, please do share the debug.log file in TXT file format, so that we could have a better idea about it. You can find more details about debugging here.

    To disable debug mode, you just only have to change the line:
    define('WP_DEBUG', true);

    To
    define('WP_DEBUG', false);

    Please let us know how that goes, have a nice day.

    Kind Regards,
    Nithin

    Kemal

    Nithin

    Its happening again and its incredibly frustrating. I think you have great plugins but it doesn't work for me. I tried several times spent several hours and days trying to smush manually because the bulk smush takes forever to only find out that I get logged out from WPDev and have to restart again. I have asked for technically help many times about this same issue and they are not able to help. This is my last time pleading for help, find a solution or I will no longer be using your service. I pray that you will. I wait to hear from you.

    Kasia Swiderska

    Hello Kemal,

    I checked debug log and found this error:

    4.3 | HTTP Error: 599 "" (https://premium.wpmudev.org/api/dashboard/v1/updates [599])

    It might be related to issue you are having. It seems to be an IP related issue, could you please contact your hosting provider to make sure that our URL isn't being blocked somehow? https://premium.wpmudev.org/api/

    There are no other errors in debug log related to WPMUDEV or Smush, only this one, so we have to check it.

    Also if you could provide IP of your server - I would like to check this also with our sysadmins.

    kind regards,
    Kasia