Is there a Comments draggable element in Upfront?

Hello,

I am trying to put comment on PAGES- not posts- in Scribe.
I was shown a screenshot of clicking "discussion settings"
and a draggable Comments element.

I do not see a draggable Comments on my site- I have 16/16 (photo)-
I do not have "discussion settings" to click on pages.
I do have that on posts where I also have comments.
When I click on it I do not get a comments draggable but a pop-up (photo).

Ultimate Facebook and wpmudev Forums are activated on my site.

Should I have a draggable comments?
Did I delete it somehow? Can I delete draggable elements?

Thanks for your help.

Peter

  • Adam Czajczyk

    Hello Peter,

    I hope you're well today and thank you for your question!

    You can use comments on pages but first you will want to enable comments for that page. By default comments for pages are disabled. Please follow these steps then:

    1. In your WordPress dashboard go to "Pages -> All pages" list and edit the page you'd like to add comments to
    2. Expand "Screen options" tab near the bottom edge of the screen and check the "discussion" check box
    3. Scroll the page down end below the content editor check the "Allow comments" check box
    4. Update page
    5. Open the page in browser end enter "Upfront" editor
    6. Drag the "Comments" element on the page; you'll see the "Discussion settings" link in editor but now comments should work on page.

    I created a short video guide for you. Please take a look here:

    http://screencast.com/t/oPCrlK6UZ2f

    I hope that helps!
    Best regards,
    Adam

  • peter

    Hi @Adam
    Thanks for your step-by-step explanation.
    I am still not getting a draggable comments.
    I deactivated Forums. Deleted the Forums link from the footer of a test page.
    No comments draggable.

    I used Bulk edit to start this and it seems to have checked comment/discussions for all my pages which is nice, but not the bottom "allow discussion"

    Anyway, I'm still not getting the little draggable comments.
    I mostly don't know what I am doing- could I have deleted the box somehow (Forums/Ultimate Facebook)
    Is there a place I can just drag it back out of?

    Double checked by following along with your video (no sound for me iMac/chrome).

    Thanks for your help and patience.

    Peter

  • Adam Czajczyk

    Hello Peter,

    Thanks for your response.

    The video doesn't include any sound, so that's perfectly fine that you don't hear it :slight_smile:

    As for the issue. I admit I'm getting a bit confused now. I've just visited your site (the page shown on your screenshot) and... the "Comments" element was there for me. Please visit the page and you should find a nice comment form there.

    That said, could you please:
    - take another screenshot and share with me - of the very same page, of the very same area as as the one I attached to this post (your previous screenshot doesn't show entire Upfront toolbox on the left)
    - let me know what browser/OS (including versions) you tried so far with no luck; an info on screen resolution and devices would also be great.

    I think that's either we're both missing something obvious here or we're on track of serious bug.

    Looking for your replay,
    Adam

  • peter

    Hi Adam Czajczyk Thanks for sticking with this.

    I was- briefly- happily surprised this evening when the comments element popped up.
    But only for the two previously mentioned pages.
    I dragged it over and now have comments on the pages (but no more element..?) -photo

    I tried this on older pages (video/ no audio) and on a brand new page and no comments element.
    (I know there is a search function but its kind of finicky for me.. separate ticket)
    http://www.youtube.com/watch?v=9Y9gL0D8kFA
    I'm thinking Upfront or something needs a day to refresh and think things over before making the change...?

    I use iMac os 10.11.3
    Chrome and Firefox

  • Adam Czajczyk

    Hello Peter,

    Thanks for your response and video. I think the "add comment procedure" can be confirmed as working fine but the issue here would be an "aggressive" caching at some stage. This can either be a cache on server (e.g. WP Engine and Go Daddy they both use that by default) that needs to "clear itself" or a strict browser caching.

    The simplest test here would be if you could first enable comments (on page edit screen in dashboard) for any page that didn't use comments so far and then logout of your site, entirely clean browser's cache, login back again and check Upfront editor

    If a "comment" element shows up immediately, the main culprit is found. If not, it will be worth to ask hosting provide about their server-enabled cache/caching policy. One way or another, there's a great chance that it would get us much closer to a solution of this riddle :slight_smile:

    As for "hidden" elements. There's not many more of them as apart of comments there are also not many other core WP features that you can turn on/off the same way.

    Best regards,
    Adam

  • peter

    Hi adam
    I cleared the browser history/cache for all browsers on my computer. No change.
    My site is hosted on Dreamhost. Dreamhost suggested DNS flush as a first step, though this can take up to 72 hours to effect a change-- so I did that. Restarted computer. No change.

    I also tried logging in from other computers that have never used my site- still no comments element.
    Went and did the comments/discussion allowed on pretty much every page 24 hours ago- no changes.

    I'm curious why the change did happen on the first two pages....

    So now, wait 72 hours and see if DNS flush will have any impact....?

    Cheers,
    Peter

  • Adam Czajczyk

    Hello Peter!

    I assume that by DNS flush you mean flushing DNS on your computer, for example in Windows you do this by issuing "ipconfig /flushdns" command in cmd terminal. Is that right? In such case there's no nee to wait as those changes take place immediately. Furthermore, I don't think that DNS cache would affect that.

    To make things even more complicated, I just visited your site and randomly checked some pages. All had "comments" button for me (Chrome/Windows). This leads me to the point that either I'm missing something obvious here or this definitely is a "cache" issue.

    You mentioned that you tried that visiting the page from other computers that never visited the page before. Where these computers running OS X as well or Windows? Where they in the same network (e.g. behind the same router or at least connected through the same internet provider)? Let me know please! I realize that so far I'm asking more questions than giving answers but we need to narrow down the trouble-generating area and eliminate all possible "weak points".

    Best regards,
    Adam

  • peter

    Hi @adamczajczyk

    Yes- I did not know what a DNS flush until going over to Dreamhost.
    There's a lot I don't know-
    including why the comments element is working now.

    Which it is- I check periodically through the day- and voila! about an hour ago. The comment element was there, so I went through and put comments on every page- just in case -voila! it is gone again.

    The other computers were macs- safari/chrome/firefox-- yes, in the same network.

    So, perhaps it is a cache issue.
    (which doesn't really make sense to me but....)

    I'll mark the issue resolved in as much as things are working now.
    Thanks for seeing this through.

    Peter

  • Predrag Dubajic

    Hi Peter,

    I just created new page on your site and after enabling comments I was able to see the comment element right away, so I added it, resized it a bit and published the page, the form was shown without any issues.
    You can check /wpmutest/ page on your site to see the form.

    Can you tell me if you tried opening it from different PC because this is really strange behaviour?

    Best regards,
    Predrag

  • peter

    Hi @dubajicp1

    Thank you for having a go at this.
    I see what you did, happy to know it worked.
    I just tried to- no luck.
    The video, no audio, show me trying from backend first and then from front end.

    I have tried from two different desktops, two laptops- all macs though.
    All up to date ios and chrome,firefox,safari- also up to date.
    Also cleared browser cache and flushed DNS on primary laptop.

    If you look at any of the pages created since March 3 (starting with "Comments timer wed 8 pm)
    you should see all the right boxes checked and not element.
    Also the pages that had the element no longer have it.
    Most pages I dragged comments on to.
    A few: Index, ABC- I had the choice and decided not to- and now I see that I no longer have the element.

    Twice comments became enabled within 48 hours of me clicking the correct buttons, now I have been waiting since March 3.

    I will be around a bunch of chromebooks tomorrow night and will try with one of those.

    https://youtu.be/Uoq_c7sQzAw

  • Milan

    Hello @missybon,

    I hope you are doing good.

    Thanks for enabling support staff access to your site. :slight_smile:

    Dear member I am not able to replicate this issue on your end. I can see comments draggable element for every one of your page. I've made double sure that element is there for every page. I am also attaching some screenshot of my testing.

    As my colleagues Adam and Predrag are also not able to replicate this issue, it seems to more systematic issue now. But on the other side you are also confirming that its not working on different mac and windows powered pcs too. It is very much strange issue indeed. :confused:

    So here is something I have in mind. Would you please add titles of those pages where you are not able to see Comments element in upfront editor and also what you want to do with it ? I will make sure element and there and apply your desire changes too. How's this sound ? If you feel confirtable with this then please take backup of your site and let me know. :slight_smile: You can leverage our Snapshot Pro plugin to take full backup of your site. :slight_smile:

    Thanks and Have a wonderful day.
    Milan

  • peter

    Milan Thank you so much, you are very kind.

    I just looked at the pages you showed me- no comments element.
    Once I used it it went away.

    My other newer pages- no comments elements option.
    I will leave those pages without comments for now- and work on finding an answer and a plan B.
    I will have to get a computer person to sit next to me and use my computer to poke around and have a look at this.
    I hope to keep adding and adding pages and pages-- with comments and comments- so I definitley need to find a way to make it work on my end.

    1) It is really ...what... the site is online and I have used different computers, so in one sense it is just me.
    2) I really appreciate having all of you look into this and at least confirm for me that I should not be understanding the problem-- that is comforting in its own way.

    I will mark this as resolved in as much as we all agree it is a mystery.
    Once I get a computer person to have a better look than I can, I will report back what they have found.

    Many thanks,
    Peter

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.