Is there a WordPress-related fix when your site is publicly visible but you can't access wp-adm

The site -- http://www.isi-companies.com/installation -- is publicly accessible but when I try to go to ../wp-admin, I get a dialog that says "Unable to load the webpage because the server sent no data. Error code: ERR_EMPTY_RESPONSE." I'm waiting to hear back from GoDaddy Support but I'm pretty sure they're going to say either there's nothing wrong or there's nothing they could do even if there is something wrong. Suggestions?

  • Vaughan
    • Support/SLS MockingJay

    hiya

    thanks for posting.

    as @decura says, you could try the above. then activate 1 by 1 and see if the issue returns.

    also try adding these to php.ini in your public_html

    memory_limit = 256M
    upload_max_filesize = 128M
    post_max_size = 128M

    hope this helps.

  • gkosovic
    • Design Lord, Child of Thor

    Many thanks, @Decura. Resetting the plugins folder using the directions you pointed me to was effective in enabling me to log into the Admin panel. then set about some editing and writing tasks. When I started to create a new post, WP seemed to lock up: the Save Draft function did not appear to complete, and Preview didn't work. Now I'm back to being unable to access wp-admin.

    I guess I'd better deactivate every plug-in one by one to see if one of them is causing all this bad behavior. Would you agree, or would you suggest another course of action?

  • gkosovic
    • Design Lord, Child of Thor

    I just finished resetting the plugins folder again and reactivating my plugins one by one. I logged out after activating a plugin, then logged in again. No apparent problem with any of the plugins.

    How would the lines I added to php.ini have affected the situation?

  • gkosovic
    • Design Lord, Child of Thor

    After another short writing session, it took minutes (I lost track of the count) for the Save Draft action to complete. Now, I can't get get off the post editing screen and to another area of the site. The browser tab says "Connecting..."

    It seems there's a problem with timing or server response or something. GoDaddy Support said they couldn't find anything amiss but said they'd be glad to have another go at it if I can produce a repeatable issue.

    I'm lost for answers at this point. Suggestions?

  • Decura
    • The Bug Hunter

    @gkosovic

    I just tested the site and the frontend seems to be working fine so there doesn't appear to be an error establishing a database connection. The wp-admin is also available. Try clearing the cache to see if that helps.

  • gkosovic
    • Design Lord, Child of Thor

    @Decura,

    I cleared my Safari cache before the first login attempt of the morning. Login was successful. I'm not aware of any plugins or settings that would force an SSL connection. The site does have an SSL certificate.

    I did a little editing of a post a few minutes ago, then went to Preview. When I came back to the post editing screen, I had to first log back in. Now, in the brief time it took to write this reply, my session has once again expired. Is there a setting to govern length of time before session expiration? Less than 5 minutes of inactivity seems like a ridiculously short time to trigger expiration.

    Many thanks,
    gkosovic

  • Decura
    • The Bug Hunter

    @gkosovic

    You can try activating the Twenty Twelve theme again, deactivate all plugins and enable them again to see if one of them is causing it. I would personally activate the plugins in clusters of 5-10 plugins if you have many. This process is a pain but it is a great way to discover the cause by process of elimination.

    Have you set the Site Address (URL) under Admin menu > Setting > General to http://yoursite.com?

  • gkosovic
    • Design Lord, Child of Thor

    @Decura

    Again, I appreciate your assistance. The site address is now set to http://mysite.com.

    I'm encountering what appear to be browser differences. The issues we've been discussing here seem worst in Safari (v6.0.5) and milder in Firefox (v22.0). After my last comment to you, I worked a while using Firefox, then got off on another task. When I returned to the post editing screen, everything was locked up -- as though I had timed out but there were no visible signs of the session having expired. I couldn't navigate to another part of the WP interface. Even Log Out registered no response.

    Is it possible there are settings or constraints placed by my web host (GoDaddy) which would be root causes of these issues?

  • Vaughan
    • Support/SLS MockingJay

    hiya

    @Decura thanks for helping out with this, some points coming your way.

    @gksovic

    could you try this.

    create a file called info.php using your editor.

    in this file place the following.

    <?php phpinfo(); ?>

    then upload it to your sites public_html folder.

    once done, you can call it with http://domain.com/info.php

    let us know the URL & we can check your PHP configuration. it could be that the PHP SESSION timeouts are too short. or maybe session.use_only_cookies is disabled.

    also whilst you're in your public_html folder, look for an error_log file, if present could you post the error messages so we can see them.

    thanks.

  • Vaughan
    • Support/SLS MockingJay

    hiya

    can you try adding this to your php.ini

    session.use_only_cookies = 1

    but it doesn't look like that php.ini is being used because the phpinfo says it's 64M

    whereas if you added those lines above, it should say 256M

    could you check with your host regarding changing php settings on your account?

    thanks

  • gkosovic
    • Design Lord, Child of Thor

    @Vaughan,

    Could you be more specific about the query to GoDaddy Support about changing php settings? Based on my past experience, they're going to say, "What do you want to know about changing PHP settings?" And I won't have a rejoinder.

  • Vaughan
    • Support/SLS MockingJay

    hiya

    lol yes that's godaddy for you. you couldn't have picked a worst host in my opinion.

    if you're in the mood for changing, i can't complain about surpasshosting.com, they're cheap, reliable & their support from my experience has always been excellent.

    ok. ask them how to change the php.ini settings for your domain.

    give them those php.ini values i gave you & tell them that's what you need to change.

    that should be enough for them to say, ok, go into your CPanel & do this.....

    or maybe it is htaccess method.

    but the php.ini doesn't seem to function or ask them how to make the php.ini recursive.

    hope this helps.

  • gkosovic
    • Design Lord, Child of Thor

    Hi @Vaughan

    Typical GoDaddy Support (GDS) experience: lovely people with limited resources for problem solving. Anyway...my call to GDS netted me (1) a statement that, yes, there are memory limitations but they can't say what they are (true!), and (2) an email containing a link to the only resource they were able to provide. Here it is: http://support.godaddy.com/help/article/1409/increasing-user-file-upload-limits-using-phpini-on-your-linux-server?locale=en&ci=46061

    I'd be curious to know what you make of the linked material. The mentions of running commands from the command line suggests to me that the information pertains to performing maintenance operations directly on a server. In any case, the only php.ini file I can find is the one that I created following your directions.

    Maybe I need to dive into one of the database tables and create or modify a setting?

  • Vaughan
    • Support/SLS MockingJay

    hiya

    you really need more than 64M

    but i've been scouring google and unless you're on a dedicated or VPS plan with godaddy, then the memory limit is hard set at 64M which can't be overriden by custom php.ini, they also do not allow wildcard DNS on their shared plans either.

    try renaming the php.ini to php5.ini

    the memory_limit shouldn't be logging you out tho. but that session.use_only_cookies is a likely culprit, so that's the 1 we really need to add for this problem (i'm hoping)

    thanks

  • Vaughan
    • Support/SLS MockingJay

    hiya

    nope still not using that php5.ini

    i see in the phpinfo it's using a php.ini from this location.

    /web/conf/php5.ini

    can you access that via FTP?

    also as @hpidriver mentioned, this could also be due to the php version which is 5.2.17

    you really should be using php 5.3.13 minimum and 5.4 recommended.

  • gkosovic
    • Design Lord, Child of Thor

    I don't know where to find /web/conf/php5.ini. I can't imagine where it would be. Any suggestions?

    I'll ask GoDaddy Support about getting a newer version of PHP.

    Up until about 10 minutes ago, I was editing a post. The Save Draft command appeared to be executing until about 1 minute ago. I'm going to upload the dialog that appeared at that point.

    Thanks to you both, @hpdriver and @Vaughan. Is it possible this is all on GoDaddy's ability to support WordPress? It seems like I'm spinning my wheels and spending a lot of time to fix something that shouldn't need fixing in the first place. I host 4 other WP sites with MacHighway and there's never been a problem.

  • Vaughan
    • Support/SLS MockingJay

    this does seem more & more to be on the side of godaddy rather than WP

    they don't have a good rep.

    the time we've wasted troubleshooting & trying to solve this today it would have been far quicker to transfer the domain to a new webhost & migrate the whole site to a new host. a lot quicker (DNS propogation not withstanding)

    even if they upgrade your PHP version, the hard limit of 64M memory will potentially cause you issues further down the line anyway depending on how busy your site gets and what plugins you plan to install.

  • gkosovic
    • Design Lord, Child of Thor

    @Vaughan,

    I don't want it to seem that I've wandered off and forgotten our bracing day of troubleshooting together. I'm still reeling from the frustration and not ready to embrace the task of moving the site to another host, even though that looks like the smart move at this point. Thanks for being there for me.

    gkosovic

  • hpidriver
    • The Crimson Coder

    Is it possible this is all on GoDaddy's ability to support WordPress?

    If they tell you that they are unable to upgrade your php to a later version I would move hosts immediately.

    Also, at this point, have you tried creating a site from scratch on your hosting (but use a different db) to see if the problem persists?

  • gkosovic
    • Design Lord, Child of Thor

    Just updated to PHP5. Unable to tell whether it's 5.3.13, as @Vaughan mentioned.

    Something very glitchy happened today. Quite a few months ago, I installed the Cloudinary plugin and tried the service. I found it intriguing and have it serving a few images to the website but I just couldn't figure out how to make it work well in combination with certain media operations in WP. Anyway, I was editing a post and saved the latest draft. When I clicked Preview, the browser served up Cloudinary's home page in the same window. I hit the Back button. From that point on, the post editing screen would appear for a few seconds, then it would be replaced by the Cloudinary home page. When I would return to the post editing screen and try to act fast and click links for other screens in the admin interface, my efforts were for naught. It was always back to Cloudinary. Having been rendered unable to log out, I had to stop the cycle of lunacy by simply closing the window.

    I deactivated the Cloudinary plugin for a while. The problem stopped but that could have been a coincidence. Since I'm making only limited use of Cloudinary, I think I'll deactivate and remove the plugin, but first I have to figure out which images are being served from Cloudinary and bring them into my server's WP environment.

    Have any of you heard of such behavior?

  • Vaughan
    • Support/SLS MockingJay

    hiya

    i can see you are now on php 5.3.24 which should be fine.

    also i see session.use_only_cookies is also now enabled. though the hard limit of 64M still there.

    can you try clearing your browsers cache & cookies? and see if you get logged out again after a period of time.

    thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.