Is there any httpd.conf configuration example

Since 1 week I try to configure domain mapping. I did everything, have the sunrise in wp-config, added a A-record pointing to the correct IP, mu site in the root. I read the instruction probably 100 times and still nothing. When entering the IP in the browser a default page comes up.

Several support request with always different answers. When there is a premium support where can I send it to?

I guess its my apache httpd.conf file. Is there any sample config? And where do I need to put it in? Pre Main Include, Pre VirtualHost Include, or Post VirtualHost Include?

I have this in the httpd.config under Pre VirtualHost Include:

NameVirtualHost 209.208.97.238:80

<VirtualHost 209.208.97.238:80>
ServerName server2014.iblog101.com
Serveralias *.iblog101.com
DocumentRoot /home/iblog101.com/
</VirtualHost>

I am on a VPS cloud server with cpanel, WHM, root access, and cloud admin panel.

  • PC

    Hello there Juergen,

    Thanks for your post and sorry about the issues you are facing.

    Here is a sample file for apache : http://httpd.apache.org/docs/2.2/vhosts/examples.html

    Can you kindly match the config with that sample and see if any changes are required. If you are still not able to get it working, I can happily have a closer look at that for you and get this fixed.

    Kindly let me know if that does not work.

    PS : Please do not post any login details on this thread, if required I will ask for them using our contact form.

    Cheers, PC

  • Juergen

    Thanks - but this one I tried already. When I put it in I get an error when restarting apache. Apache restart failed.The entire error message looks like this:
    -----

    Apache restart failed. Unable to load pid from pid file and no httpd process found in process list.

    If apache restart reported success but it failed soon after, it may be caused by oddities with mod_ssl.

    You should run /usr/local/cpanel/scripts/ssl_crt_status as part of your troubleshooting process. Pass it --help for more details.

    Also be sure to examine apache's various log files.
    Apache restart failed. Unable to load pid from pid file and no httpd process found in process list.

    If apache restart reported success but it failed soon after, it may be caused by oddities with mod_ssl.

    You should run /usr/local/cpanel/scripts/ssl_crt_status as part of your troubleshooting process. Pass it --help for more details.

    Also be sure to examine apache's various log files.
    Apache Restart Output:

    Log:
    [Tue Dec 17 10:55:48 2013] [error] [client 91.66.99.219] File does not exist: /home/iblog101.com
    [Tue Dec 17 10:55:48 2013] [error] [client 91.66.99.219] File does not exist: /home/iblog101.com
    [Tue Dec 17 10:55:49 2013] [error] [client 91.66.99.219] File does not exist: /home/iblog101.com
    [Tue Dec 17 10:55:49 2013] [error] [client 91.66.99.219] File does not exist: /home/iblog101.com
    [Tue Dec 17 11:01:33 2013] [notice] caught SIGTERM, shutting down
    [Tue Dec 17 11:01:34 2013] [notice] SSL FIPS mode disabled
    [Tue Dec 17 11:01:34 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Tue Dec 17 11:05:13 2013] [notice] SSL FIPS mode disabled
    [Tue Dec 17 11:05:13 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Tue Dec 17 11:08:06 2013] [notice] SSL FIPS mode disabled
    [Tue Dec 17 11:08:06 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    ------

    Note Home Directory/home/iblog101 <-this is what I put in, not Home Directory /home/iblog101.com