is tinymce editor needed for wordpress5?

Hi,
I have support access on for aficreditsolutions.com and I'm trying to clean up unneeded plugins. Is TinyMCE Advanced and Chase Text Case needed in wordpress 5 or can these be removed?