Is WPMU Dev necessary for Smush?

All I want to do is use Smush Pro,. I really try to eliminate any unnecessary plugins. Does Smush Pro REQUIRE WPMU?

I want to uninstall WPMU and just manage smush pro on its own.

Is that ok?

  • Kasia Swiderska

    Hello Craig,

    You don't need to use WPMU DEV Dashboard to use WP Smush. Please add the following line to your wp-config.php replace the "API KEY HERE" text with your api key, you can find your api key by clicking this link https://premium.wpmudev.org/hub/account/ when logged in to our main site.

    define( 'WPMUDEV_APIKEY','API KEY HERE');

    However - with WPMU DEV it will be easier to update WP Smush Pro.

    kind regards,
    Kasia

  • Madhusudan

    Hello Craig,
    Hope you are doing fine.
    To manually update a plugin here are the steps:

    1. Take a full backup of your site first (recommended even if you are updating automatically) for a restore point.

    2. Deactivate the plugin(s) first that you want to update.

    3. Delete the plugin(s).

    3. Download the plugin from project page, for example go here for WPMUDEV Dashboard plugin.

    4.a Go to Admin > Plugins > Add New > Upload Plugin, chose file, install and activate (basic).

    4.b Go to following location by using FTP or FileManager, extract/unzip plugin folder and upload (advanced).

    wp-content/plugins

    5. Done!

    Hope that helps! If you still need assistance, please don't hesitate to ask.

    Thanking you,
    Madhusudan Pokharel

  • Craig

    I did that. I deleted both and manually installed 215 zip.

    I do get the message "Important updates are available for your WPMU DEV plugins/themes. Install the free WPMU DEV Dashboard plugin now for updates and support!
    Install WPMU DEV Dashboard More Info»"

    Also it is still giving me a nagging false update notice on plugins page -- WP Smush Pro
    Settings | Deactivate Reduce image file sizes, improve performance and boost your SEO using the WPMU DEV WordPress Smush API.
    Version 2.1.5 | By WPMU DEV | View details

    There is a new version of WP Smush Pro available on WPMU DEV. View version 2.1.5 details or Install WPMU DEV Dashboard to update.

  • Craig

    Under updates needed now --

    Plugins

    The following plugins have new versions available. Check the ones you want to update and then click “Update Plugins”.

    Update Plugins

    Select All
    WP Smush Pro
    You have version 2.1.5 installed. Update to 2.1.5. View version 2.1.5 details.
    Compatibility with WordPress 4.4.2: 100% (according to its author)
    Fixed: WP Media Folder Plugin compatibility Fixed: Warning on Plugins Page Updated: Settings Page styling

    Select All

    I really don't have time to mess around with this if it can't update correctly. I think it is couple to the Dev dashboard which won't let go. I may need to quit using Smush Pro if it is going to be so difficult to just use Smush Pro.

  • Rupok

    Hi Craig

    Hope you had a wonderful day.

    I really don't have time to mess around with this if it can't update correctly.

    Don't worry at all. Just take a full backup of your site and update the plugin. I highly believe there won't be any issue, but even if there are, you can easily revert back to current state.

    I may need to quit using Smush Pro if it is going to be so difficult to just use Smush Pro

    I believe you won't have to quit using Smush Pro because it's the best of its kind and usage is really easy. Feel free to contact us whenever you face any problem. You have a fully dedicated support team with you.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Craig

    Hope you had a wonderful day.

    I really do apologize that I could not understand you still have the problem is the point. But we are discussing about couple of notices, requirement of WPMU DEV Dashboard plugin, update without Dashboard plugin etc. and there was no clear indication of "the problem".

    I do get the message "Important updates are available for your WPMU DEV plugins/themes. Install the free WPMU DEV Dashboard plugin now for updates and support!
    Install WPMU DEV Dashboard More Info»"

    First of all, this is not related with Smush Pro. This is our generic offering to our users. We offer this to our users because most of them feel easy to install/update our plugins through our Dashboard Plugin. So this didn't indicate you are looking for a fix.

    There is a new version of WP Smush Pro available on WPMU DEV. View version 2.1.5 details or Install WPMU DEV Dashboard to update

    For the same reason as above, we offer our users updates through our Dashboard plugin as it's easy. And it's not stopping Smush Pro in working. As your thread title is "Is WPMU Dev necessary for Smush?", I didn't understand that your problem is this and you are asking a fix for this.

    When you said "Under updates needed now", you provided the plugin list. But there was no indication what you exactly need.

    I still have the problem is the point. I manually installed the plugin and now it is reporting that I need to install the Dashboard and update the plugin

    Now this clearly indicates what is the problem you are facing and now I can work on this. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I'm looking forward to hear from you and resolve your issues as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Craig

    Let's try it again.

    I just want to run Smush Pro on this site. I do not want to run Dashboard or WPMU.

    I uninstalled Smush Pro and WPMU/Dashboard. WPMU does not work thru my firewall.
    I installed latest version of SmushPro I was trying to get to.

    Now I am nagged that toinstall Dashboard

    Important updates are available for your WPMU DEV plugins/themes. Install the free WPMU DEV Dashboard plugin now for updates and support!

    And even though I have latest SmushPro it thinks I need to update

    There is a new version of WP Smush Pro available on WPMU DEV. View version 2.1.5 details or Install WPMU DEV Dashboard to update.

    Note too that I have WPMUDEV API defined in my wp-config file

    define( 'WPMUDEV_APIKEY', 'xxxxxxxxxxxxxxxxxxxxxxxx59198' );

    I don't mind granting access but so far I have not seen any constructive replies so I am hesitant.

    If you would like to call and check on this that is fine. 303-261-8836 or craig.keefner skype.

    I have the Dashboard installed on other sites and use it fine though I am still not sure why I need to use it. Apparently SmushPro will not quietly operate without it.

    Thanks Rupok. I hope it is clearer to you now.

    Craig

  • Kasia Swiderska

    Hello Craig,

    I'm sorry for all of confusion and questions on our side. We would like to ask temporary access to your site because we can't replicate issue with false positive update nag and we would like to check this issue on your site.
    I just tested Smush Pro without the WPMU DEV plugin and there is only nag about the installing the WPMU DEV plugin.

    I prepared small MU-plugin ( https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/ ) that will help with the nag on plugin page. I'm attaching it to this post (it needs to be unzipped first).

    Also we are not allowed to communicate with our members through unsupervised channels.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.