Issue - deprecated code (google maps)

When I activate the google maps plugin there is an error in the error.log

[Fri Feb 19 15:57:31.201131 2016] [fcgid:warn] [pid 22886] [client 188.205.136.66:34443] mod_fcgid: stderr: PHP Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0!. Use __construct() instead. in /xxxx.nl/httpdocs/new01/wp-includes/functions.php on line 3624, referer: http://www.syslogic.nl/new01/

  • Adam Czajczyk

    Hello R.M. Repko,

    I hope you're having a nice day!

    It seems that's another warning that's a result of the very same reason: the PHP version used on your server. It looks like on your server PHP configuration is set to be very "strict" if it comes to displaying errors and notices.

    For this an all other similar issues, this should help:

    1. Add this line to your "wp-config.php" file:

    define("WP_DEBUG", false);

    or, in case it didn't work

    2.
    - create an empty file named "php.ini"
    - put these lines inside

    display_errors = Off
    display_startup_errors = Off
    log_errors = On
    ignore_repeated_errors = On
    ignore_repeated_source = Off
    html_errors = Off

    - save and upload that file to the root folder of your WP install.

    PLEASE NOTE: I've updated the thread I linked to in my responses to your other threads (see last post there) as I noticed that it was outdated. It's now up to date.

    Let me know please if it worked!

    Best regards,
    Adam