Issue for new members sign up with activation

Hi,

I have a number of WPMU plugins used for my site (www.mywebdoctor.co.uk). The main one I am concerned with is Membership Pro.

I had it set for a free trial for 30 days for new members, which then automatically turned into a normal billing cycle just like in this thread (https://premium.wpmudev.org/forums/topic/creating-a-trial-membership)

It was fine, but now the site asks for user activation via email (which I believe is via the BuddyPress plugin). This activation never works and the site becomes stale.

I need the initial signup to give the members a username / password and then proceed directly to the PayPal screen in order to collect the users details ready to start billing after the initial free period.

I can't seem to get past this activation screen ... any help you have is greatly appreciated.

I have enabled the backend support for you if you needed to have a look.

Kind regards

  • calvinrogercanas
    • New Recruit

    Hey there @REBECCA,

    Hope you're well! :slight_smile:

    If you're using buddypress then I don't think you need to set any buddypress register page, just the membership one.

    To do that navigate to Admin -> Settings -> BuddyPress -> Pages[tab] -> Register set to "None" like this: http://prntscr.com/67h8sm

    No activation email will be send and your user will be logged in right away after signing up.

    Let me know if it helps! :slight_smile:

    Best Regards,
    Calvin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.