Issue on manual smush and bulk optimization

The progress of bulk optimizion runs for hours (12) but it only optimize a few of images. I refreshed the page so the optimizaion tool continue is optimizaion, but ptimize once again just few images. It looks that i s running but isn't so (or maybe is only the counter that doesn`t upadete live?)

The second problem is that if i try to smush manually from the emdia library more of images aren`t supported; Invalid file format. Only PNG, JPEG, and GIF files are supported. But they are norma JPG file that in other case the plugin smush normally. So i think is not the file format.

Thanks.

  • Jude
    • DEV MAN

    Hi there Fabio,

    Do you have any security plugins or caching plugins installed at all, or are you using a CDN service at all? if so can you try disabling them and see if that helps?

    Looks like your host has restrictions on either time limit or memory on your processes, maybe you can take a look at the settings in your PHP handler ?

    Cheers
    Jude

  • Fabio
    • New Recruit

    Hi, my site is running in a Vps but i`m not the administrator of the server. I have no security plugins. How can I set a new limit for the the process? I red online few website, and I tried to write code in the htacess, in the config.php and also searche dthe php.ini but didn't found it! I appreciate your help. Thanks.

  • Jude
    • DEV MAN

    Hi there @Fabio

    I just logged in and reset the queue, if the issue persists then try the simple steps shown here to increase the memory limit. Set it high like 192MB - 256MB temporarily.

    docs.woothemes.com/document/increasing-the-wordpress-memory-limit/

    Also delete the plugin folder and manually install it once again.

    Cheers
    Jude

  • Fabio
    • New Recruit

    Hi, I tried all of your tips but the issue is still live. Im not conviced that the problem is the memory and that is the reason: i found out that some files extensions are always processed correctly, like png (you can test it) and other, like jpg sometimes are processed and sometimes not (in the manual optimization, for example if you click on a jpg image 10 times for 10 times the plugin doesnt smush this file). So, my opinion is that the problem is with some images and during the bulk optimization the process stops just when one of those image can`t be processed. Can you verify this please? This should be a plugin bug. Thanks.

  • Jude
    • DEV MAN

    Hi again @Fabio

    So, my opinion is that the problem is with some images and during the bulk optimization the process stops just when one of those image can`t be processed. Can you verify this please? This should be a plugin bug. Thanks.

    I too would think this except that I know that 10000s of people use this plugin with all those extensions just fine. I myself have handled so many Smush tickets and have never had this issue.

    I will anyway consult with the developer just to be certain.

    I'm not conviced that the problem is the memory and that is the reason: i found out that some files extensions are always processed correctly,

    I pursued the memory angle because I was logged into your dashboard earlier today and it was painfully slow. Even the Smush process was one of the slowest I've seen. What happens here is your server just sends the images to our server, the smush process itself happens on our infra. But this send itself was taking unusually long.

    Did you try to delete the plugin via FTP and install it again ?

    Failing that, can you try following the advice in the following thread to see if this works for you?

    https://premium.wpmudev.org/forums/topic/are-the-smush-servers-working#post-801839

    Cheers
    Jude

  • Fabio
    • New Recruit

    Dear Jude i tried all your suggestion like reset the bulk status (the bulk optimization reinitialize but stops at the same point). I have also contacted the administrator of the server, as you can see in http://www.leggereacolori.com/info.php the memory limit set it`s optimal, so the max execution time. We didn't find a server side problem. So please give us a solution or I must cancel the subscription of Wpmudev and ask for refunding (suddenly!).

    Thanks in advance for your help.

  • Jude
    • DEV MAN

    Hi again Fabio

    Can you please send in

    Subject: "Attn: Jude Rosario"
    - WordPress super admin/ admin username + password
    - FTP credentials (host/username/password)
    - cPanel details
    - phpMyAdmin details ( To check database )
    - MySQL details ( IF you dont have phpmyadmin)

    -link back to this thread for reference

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Cheers
    Jude

  • Umesh Kumar
    • Code Wrangler

    Hi @Fabio,

    Manual and Bulk smush are stuck, as you seem to be using Ewww Image optimiser earlier, which registered the webp images for each size. Smush pro doesn't optimise the webp images and hence a result you are getting the image not supported error.

    To resolve that, you've to regenerate thumbnails using the plugin, which will automatically optimise them, but the images created by Ewww, will be overwritten.

    Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.