issue setting up child theme without loosing changes?

Hi,
Im having a little trouble with the child theme on my site: http://tinyurl.com/ztpdn54
current theme: storefront
newly created child theme: storefront-xxxxxxxxxx-child (x = site name) screenshot - http://take.ms/eyv9U
The issue is when switching to the new theme, even though i have checked and paste in the CSS changes to the Custom CSS plugin there is some clear visual changes between the two themes. I think i may have forgotten to move some code or a file but im not really sure what to look for ?

FTP screenshots
- http://take.ms/wXUg9

style.css file - http://pastebin.com/u2dWnYRh (expire in 1 week)
footer.php file - http://pastebin.com/3gpqVf4S (expire in 1 week)
functions.php file - http://pastebin.com/PyUCk5Fg (expire in 1 week)
header.php file - http://pastebin.com/ygj6PgkJ (expire in 1 week)
I have enabled support access on the site. and can send FTP details if required?

thanks
Tom

  • Sajid

    Hi @Tom,

    Hope you are doing good today :slight_smile:

    The issue does not seems to be with your style.css and also should not be with Custom CSS section since its in the database.

    The issue is with theme customizer. I can see you have made lots of changes in Admin > Themes > Customizer. WordPress save the customizer settings with themes prefix in options table so when you change your theme the, its prefix change and changes lost and reverts to default.

    I would suggest you to contact WooThemes support to get help regarding this matter. I am sure they must have confronted this issue in the past and have might have better suggestions to rule this out.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.