Issue Setting Up Ultimate Facebook Plugin

When setting up the Facebook plugin I continually get the "Please, enter correct Facebook API settings" even though my API information is correct.
The tutorial on the site is out of date, I've set up an App a few months ago and all went smooth. It looks like facebook has updated its developer portal since then.