Issue that i think may have messed registration

I have already opened a thread about an issue that i have no issue as to its cause.

https://premium.wpmudev.org/forums/topic/helppppppp-urgent-problem-points-reward

However i now believe it may be a result of the multisite privacy plugin.

However as a result of below i believe that this plugin may be the issue.

Ok so i just reinstalled multisite privacy to see if there are settings that still exist and if so can i remove them from the tables etc.

However as soon as i activate it i get the following”Applying to sites, please wait…”

This means the only way to gain access to my network admin is to delete the plugin via ftp

Any Ideas anyone?

  • Ashley Keable
    • The Incredible Code Injector

    Well i have looked at the blogs table and all have the correct value.

    I have attached a screenshot of what happens upon registration. Note wordpress sends 2 emails at the same time as each other.

    1 is the default email you would activate and then receive your password via a second email. The second is the email you would expect if you have already chosen your password.

    Please also note that both have different urls attached to the activation key that may give a clue.

  • Tom Eagles
    • Syntax Hero

    @ashley Keable ahh mingle!!

    yep i got both used the one with the tomincsub.yourdomain.com in it

    worked perfectly site created and logged in under users shows me as an admin.

    Just a thought do you have any other email plugins running, are you using wp’s email function?

    Next up try using the smtp for wordpress plugin from wordpress.org use that to bypass the integrated mailing function. see if that solves it.

    Cheers

    Tom

  • Ashley Keable
    • The Incredible Code Injector

    @tom.eagles

    Yes i can see you created your site and the issue was never that you wouldn’t be an admin so i apologise for not describing properly. What i mean was that the blog would not show on the blog directory however i have just realised there is a delay as its now showing.

    Just need to resolve this issue with the duplicate email and the fact it emails a password.

    Now you mentioned the email option i think i know what has broken. I am actually using the following to handle all emails WP SMTP Config

    However prior to using this i tried out the following plugin WP Mail Options

    but due to how complicated it was and how i could not get it to work i gave up and chose the current one im using.

    Therefore there is a very high chance that this may have broken something and caused these issues. I just need to try and work out what this could have possibly changed in order to fix it.

    It was very complicated and i tried different varibles.

    Any ideas? Whilst i know it would probably be difficult to work out the exact problem i could always overwrite all the parts it changes.

    I think this may actually change the php files but not sure

  • Ashley Keable
    • The Incredible Code Injector

    I have tried reinstalling wordpress from the wordpress dashboard and i have manually overwritten the wordpress files and neither method made a difference.

    Therefore i assume this plugin doesnt replace anything php wise. Unless i have missed anything, i assume the file that handles emails for wordpress is in wp-includes?

  • S H Mohanjith
    • Developer

    I’m not sure what’s causing double activation mails, but I’m not too worried because the activation key is the same.

    Do you know what privacy settings you had? If you had the main site privacy to set to anything that would require the user to login activations will never be practical.

  • Ashley Keable
    • The Incredible Code Injector

    Well i have removed this plugin but weirdly if i reinstall it and network activiate. Instantly im locked out of netowork admin and presented with: Applying to sites, please wait…

    0 of 4 sites updated

    I dont see how i can possibly remove this and as said previously this could be causing the issue as its definately not normal behaviour.

    Like i said it happens as soon as activated so i have to delete to remove. Clearly something got stuck.

  • Ashley Keable
    • The Incredible Code Injector

    @mohanjith

    Yes but very weird how its sending them twice and from the main blog and sub blog. Not to mention like i said depsite entering password it emails one to the new members upon activation.

    Its almost as if its running 2 processes at once, feel free to signup to try.

    To answer your question regarding the privacy settings:

    I had them set to allow sites access from all visitors and to index into google.

    I stopped members being able to override and remove it from signup.

    However it still showed on signup and members could remove, hence trying to change settings to which it is at that point the thing stuck.

  • Tom Eagles
    • Syntax Hero

    Hiya, just going through some of the older threads here.

    As it’s been a little while since we last heard from you I thought I’d check in to see how you’re going?

    If you’re still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.

    Cheers!

    Tom

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.