Issue Theme and Private Messaging Plugin

Upload files is not permitted with Private Messaging and Issue Theme. Users who want to upload a file when sending a message to admin are unable to do so. All that appears is a blank page. Please see attached.

Access to the website has been granted for support.

  • Kasia Swiderska

    Hello F. Zaria,

    I can see issue on your site, but I cannot replicate it on my site where I have Issue theme installed and activated.
    There could be different reason for this not working, other than Issue theme - please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart). Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    kind regards,
    Kasia

  • FZCU

    Kasia:

    To clarify, I am using Private Messaging on the front end. This issue is occurring on the front end for me as an administrator. When I create another user role, such as a subscriber, it does not occur. On a side note, Subscribers get an upload screen. But, in attempting to attach the file, the following error message shows up "You don't have permission to attach files to this post" - Please see image for more information.

  • Nithin

    Hi F. Zaria,

    Hope you are doing good today. :slight_smile:

    I checked your website, and I was able to replicate a conflict with Upfront, and Private messaging plugin. When I try to upload a file in the frontend, I was getting a blank media library image, as shown in the screenshot below. I'm reporting this to the developer, and will ask to give a look on this. I'm marking this thread so that you get an update when a fix is released regrading this issue.

    I was able to notice, http error when trying to upload an image in the backend, but I wasn't able to repliacte the issue of You don't have permission to attach files to this post as shown in your sceenshot.

    Could you please get in touch with your host, and check whether GD Library module is installed, and enabled in your server. It seems like you are running PHP v 5.3, would recommend you to update PHP at least to the recommend minimum version of 5.6. Version 5.6, should have GD Library installed by default.
    https://wordpress.org/about/requirements/

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hey F. Zaria,

    Hope you are doing good today. :slight_smile:

    To follow up, I have increased php to 7.x, but issue persists. Support has been enabled on the site.

    I checked your system, but I wasn't able to replicate the http error, could you please specify where are you still seeing the issue? I recommend GD library, because I was able to notice http error while uploading images in the gallery, not it seems to work fine. Could you please advise what I'm missing here?

    Regarding the bug, the developers are currently working on it. At the moment, I don't have an exact ETA on when a patch will be released regarding this bug. Will definitely keep you posted asap, once we have a fix.

    Kind Regards,
    Nithin

  • Nithin

    Hi F. Zaria,

    Hope you are doing good today. :slight_smile:

    Perhaps it is only occurring to me as an admin?

    I don't think that would be the reason, because when we access your website through support access, we would have all the admin capabilities. And I wasn't able to replicate this issue when I checked your website.

    Are you still getting the same errors as you have posted in your screenshot? If yes, this is really odd, because when I test, it works fine in your system. Could you please send us a screenshot of your whole page which includes the link, so that I could check whether I'm missing out anything.

    If you still think, it's related to your account, you could create a new user account, and check whether you still have the same issue.

    Please clear your browser cache, and check whether it works fine. Also, try in a different browser too.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin