Issue with appointements : time delay

When I select a time in a calendar and make a reservation, for example at 11:00, in reminder mails, "my appointements" and appointements menus it shows 7:00
Thanks for your help

  • pxwm

    Hi,

    I would really need to view all your settings and it may be easier if are in agreement to provide me with a temporary admin log-in.

    If so could you send to steve.billington@pxwm.co.uk.
    Could you confirm if the site is live.

    If not could you screenpost the following:-

    All your settings in the 'General' tab
    All your settings in the 'Working Hours' tab
    A snapshot of the 'Services' you have setup

    Could you provide a url of the appointment calendar

    If you have access it may be useful if you could confirm the time zone setting for your server. It should be set to UTC whereas your Wordpress timezone should be your local time zone.

    Regards
    SteveB

  • pxwm

    Hi,

    I've checked all the settings and made some test appointments.

    I confirmed that the server and local settings appear to be correct so at this stage I don't think the problem relates to this.

    I then made some temporary changes to a few setting such as:-

    1. Set 'Payment required' to 'No'
    2. Removed 'assigned dummy service to'
    3. Set 'log-in required' to 'No' but this didn't seem to allow me to view the appointment page without being logged in so not sure if there is a conflict with the ecommerce plug-in.

    To confirm I have reversed these changes.

    However I did prove that if you make an appointment it shows 5 hours earlier than booked. However if you then go in to the A+ backend and change the appointment time to the actual time of the booking and save it shows the correct time in the front end calendar indicating there may be a conflict with another plug-in.

    e.g. made a booking for 19/5/13 at 16:00 and initially shows as booked for 11:00 and it shows as this time as being booked in the A+ backend. If you then go to the A+ backend and change the time back to 16:00 it shows correctly.

    I also noticed in the 'General' tab you have the 'Assign dummy service providers to' set to 'Administrateur' but you don't have any of the service providers checkbox ticked to indicate they are a 'dummy' service provider. However I have confirmed this doesn't appear to be causing the problem.

    You also seem to have fields in the 'General' tab for the wpmu membership and marketpress plug-in yet I can't see them in your plug-in list but I do see woocommerce.

    Out of interest did you install the wpmu membership and marketpress plug-in and then remove them?

    I think the next steps are as follows:-

    If you did install the membership and marketpress plugins then you may wish to consider uninstalling A+, deactivating all the other plug-ins and then installing a fresh installation for A+ and carryout further tests whilst the other plug-ins are deactivated.

    If this doesn't solve the problem you may wish to revert the theme to the default theme and whilst the other plug-ins are still deactivated carryout further tests.

    Please let me know how you get on.

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.