Issue with Appointment date and confirmation email

Hi,

I am using the Appointments+ version 1.9.4.

When I am saving an appointment in WordPress, the start time is always set at 0 h 00 min. Even if I change it back to the correct start time.

Moreover, if the box Confirm is not cheked, an confirmation email is always sent to the contact.

Could you please help out ?

  • Adam Czajczyk
    • Support Gorilla

    Hello vert,

    I hope you’re well today and thank you for your question!

    I have just tried to replicate this on my test setup but I wasn’t able to: there was a proper hour set and no confirmation e-mail sent.

    I would like to take a closer look at your site then so I could try to mirror your settings and then test it again and also test it on your site directly to see how it works and what may be causing this.

    Would you mind granting me a support access so I could do this? Here’s a guide on enabling support access via our “WPMU DEV Dashboard” plugin:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,

    Adam

  • Milan
    • WordPress Wizard

    Hello vert ,

    Hope you are doing well today and won’t mind me chiming here. :slight_smile:

    I checked your site and was able to replicate issue, but I can’t replicate this on my installation. One thing I noticed in your Appointments+’s configuration is that, you have not created any service provider for your services. Please note that Appointments+ at least needs one service provider ( he/she could be dummy if you want ) to function properly.

    Although this is not quite obvious related but please do create one service provider and then try to create appointments and check.

    If it does not work even after creating service provider, please go ahead and enable debug mode for your site. To do that you would need to edit your site’s wp-config.php file. So please

    #1) Open it and find this line

    define ( "WP_DEBUG", false );

    and replace it with these lines

    define("WP_DEBUG", true );
    define("WP_DEBUG_LOG", true );
    define("WP_DEBUG_DISPLAY", false );

    #2) Save the file.

    #3) Add new appointments. Check email to know if shows proper time or not.

    #4) If email content is not showing proper time, please go to /wp-content folder of your site and find there file named debug.log. Download it to your machine. Rename it as debug.txt and attach it in your next reply.

    I also did plugin conflict test on your site but it also didn’t help. One more thing I noticed on your site is that you are using many outdated plugins ( plugins which require update ), its not quite similar but if you could update those and then test ?

    Look forward to hearing back from you. :slight_smile:

    Best Regards,

    Milan

    Best Regards,

    Milan

  • Predrag Dubajic
    • Support

    Hi Vert,

    Debug file looks clean, there are few notifications coming from the theme but those shouldn’t be affecting A+ or your site functionality in any way.

    Unfortunately support access has expired in the meantime so I couldn’t have another look at this issue, could you please grant it again?

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi vert,

    Thanks for granting access, I did some further testing and was actually able to find the culprit of the issue and replicate it on my installation.

    What’s causing it your time format setting, you have “G h i min” selected and same option causes this for me, switching it to “g:i A” or “H:i” does the trick and saves the time properly.

    I have reported this issue to our developers so they can see how it can be dealt with in future updates.

    As for the email issue, I wasn’t able to replicate that on your installation as I didn’t receive any email if email field was disabled.

    Can you tell me which account you used as client, did you enter new details or you used existing admin or provider account?

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Frank,

    We are currently testing a fix for this that will come with the next release, however we still have some other issues that need to be addressed before the update is live so I’m afraid that we can’t give any ETA yet but we’re hoping to see it soon. :slight_smile:

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.