Issue with Appointments+ Plugin

Hello,

I am having issues with Appointments+. This is a test site so you can have at it should you need to as it will not compromise anything on our end. Site and appointment page is below.

http://yourjunkhauledaway01.lordecdev.com/make-an-appointment/

First off, with Appointments+ plugin enabled, we get following notification error in dashboard...

Notice: Trying to get property of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/appointments/appointments.php on line 872

With google maps plugin enabled, we in addition get the following notification error in dashboard and rendered webpage...

Notice: The called constructor method for WP_Widget in AgmMapsWidget is deprecated since version 4.3.0! Use
__construct()
instead. in /opt/bitnami/apps/wordpress/htdocs/wp-includes/functions.php on line 3718

I have since disabled google maps but would like to be able to use it with Appointments+.

Appointments+ seems to work fine but the confirmation emails (auto confirm enabled) seems to have stopped working. Automatic appointment reminders and manual confirmation send works fine

Additionally, if not logged in to the admin dashboard, the time slot selection does not present itself when a day slot in calendar is selected. I can only select time slot if logged into the admin dashboard... if not then unable to display available time slots for a given day -- I do not want a potential customer to have to log in first to book an appointment, it is an unnecessary pain point.

Lastly, some step by step in setting up Client ID, Client Secret for Google Calendar API integration would be useful. I spent the best part of 2 hours trying to figure it out and to get it working. The one image along with link to google console in the Google Calendar tab is inadequate in my opinion. When in the google console, one is left to figure what service is required etc etc. Live Chat informed me that there are step by step slides under the Google Calendar tab in Appointments+ settings showing what to do but I was not successful in finding them. Live Chat said that I must have some type of incompatibility issue and to inform Support. Consider yourself informed. :slight_smile:

Anyhow that aside, I would like to get Appointment+ / Google Maps sorted and working properly for now.

Support Access has been enabled. I hope I have made sense. Thanks in advance for your help.

Regards,

James

  • Jude

    Hi there James

    Hope you are keeping well !

    First off, with Appointments+ plugin enabled, we get following notification error in dashboard...

    Was able to notice this when I logged in. Will get that reported. Should be harmless, you can temporarily turn off notices
    http://www.pc-freak.net/blog/turn-php-notices/

    Appointments+ seems to work fine but the confirmation emails (auto confirm enabled) seems to have stopped working. Automatic appointment reminders and manual confirmation send works fine

    Hmm strange. Can you please switch to SMTP to send outgoing email ? And try again.

    https://wordpress.org/plugins/wp-smtp/

    Lastly, some step by step in setting up Client ID, Client Secret for Google Calendar API integration would be useful. I spent the best part of 2 hours trying to figure it out and to get it working.

    Can you tell me which specific step you are getting stuck at. Will be happy to guide you step by step

    Cheers
    Jude

  • James

    Thank you Jude for your reply. What about...

    Additionally, if not logged in to the admin dashboard, the time slot selection does not present itself when a day slot in calendar is selected. I can only select time slot if logged into the admin dashboard... if not then unable to display available time slots for a given day -- I do not want a potential customer to have to log in first to book an appointment, it is an unnecessary pain point.

    That is a concern also. Your thoughts are appreciated.

  • Luís

    Hi James ,

    Hope you're doing well today!

    This issue is related to the "Use Built-in Cache" feature of Appointments +. I was able to replicate it using an Upfront theme and this feature, so, I've confirmed this bug and flagged the developer so they can get it fixed up asap. Either myself or the developer will reply back here once we have pushed a fix out.

    In meantime, I can only suggest you disable it in Appointments -> Settings, Advanced Settings section.

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.