Issue with autocompletion if last unit has only text

I may have identified a potential bug.

On our installation if the last unit does not have a question instead of issuing an email with a certificate link it presents a pre-completion message.

That is: It indicates that the student has successfully completed the course and it will be assessed by the instructor/teacher.

To confirm a unit with no question works fine as long as it isn't the last unit.

I instigated a live chat with one of your colleagues over the weekend and they confirmed they can replicate.

I agreed with them to set up a staging site just with CoursePress Pro installed so I can eliminate an plugin conflict.

Not sure if you wish to report to the developers before I test or wait until I confirm.

Regards
SteveB

  • pxwm
    • WP Core Meltdown

    Hi Predag

    Many thanks for creating the new post.

    To confirm I've created a staging site with just CoursePress Pro installed so I could eliminate any plugin conflicts.

    I can confirm that I created simple course as follows:-

    1st unit has 2 x questions
    2nd unit was just text

    When the student completes the course they receive a notification that they have successfully completed the course and it will be assessed by the instructor.

    I can confirm that this is placed in the assessment section

    I then switched the units around as follows:-

    1st unit was just text
    2nd unit has 2 x questions

    This then provides the student with a success notification with a certificate link and in the assessment area it shows Certified in Green and 100%

    Further testing - It would appear that you can have a mix of units with and without questions as long as the last unit includes questions and it will then issue a certificate based on the course criteria.

    If you would like me to make further tests please let me know.

    I hope this helps

    Regards
    SteveB

  • Josh
    • Design Lord, Child of Thor

    Hello Steve,

    We are having a similar problem with our Coursepress Pro and I have opened a ticket that Jame Morris is looking into. Specifically, when a student completes a course that an admin has made a unit-change to (and saved), the student only gets to a pre-completion page -- not the Completion page with Certification link as configured.

    Today is April 24th. Is there any update to the 2.1.6 package being worked on ?

    Best Regards,
    Josh

  • pxwm
    • WP Core Meltdown

    Hi Josh,

    Sadly no update since Adam responded on 2nd April.
    Using workaround at the moment by ensuring the last unit includes a question.
    I'm hoping we are nearing the release of v2.1.6 as it is now 6 weeks since the issue was confirmed as a bug.
    Hoping a wpmu staff member can provide us with an update.

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi Predag,

    I've just noticed there has been an update to Coursepress Pro to v2.2.

    I've just read the changelog but it doesn't appear to include resolving the bug relating to my post.

    Before I upgrade I would appreciate if you could confirm if v2.2 does include a resolution relating to the bug I reported in this post.

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.