Issue with blog archive pages

Hi.
Please check my blog archive on https://www.beetellstories.com/beeswax/

This page loads fully. However, apart from the header and footer, the page itself cannot be viewed on the front-end... just shows as a white screen. I can see the content is loaded if I copy-all and paste elsewhere but the page is still only showing this white screen. Will truly appreciate if someone could help me understand why this is happening and how to resolve.

Thanks.

    • originaldruider
      • Design Lord, Child of Thor

      Hi Predrag Dubajic,

      Thanks for the response.

      I cannot say at what stage of Hummingbird this option cropped up. I activated Hummingbird and configured all the options, including asset optimisation, in one go. And then when I went to my blog page, the content was not visible, even though I could see it if I copy-pasted the page and also in source. Turning off page caching in Hummingbird didn't resolve the issue. Deactivating Hummingbird did. I am enabling support access now for this site.

      Thanks.

  • Adam Czajczyk
    • Support Gorilla

    Hello originaldruider

    Thanks for enabling support access.

    I have checked the site. I've enabled Hummingbird and made sure that Asset Optimization is enabled (but didn't make any changes whatsoever) and the issue didn't happen.

    However, I think that doesn't mean that it's not there. I have noticed that you got SG Optimizer (SiteGround's caching plugin) enabled and configured. That's something that is very likely (I think it actually do) to cause conflicts: there should never be two "full page caches" active on the same site at once and any "full page cache" should also be disabled during Asset Optimization configuration.

    Here's what I'd suggest to do:

    1. Go to SG Optimizer settings page and first purge cache then disable it
    2. Then disable the SG Optimizer plugin entirely
    3. Then login to hosting panel (cPanel - to manage server) and look if there are any other caching tools enabled; if so, clear caches and disable.

    4. Get back to your site and enable Hummingbird again (I've disabled it after checking the site)
    5. Go to Asset Optimization and re-check files
    7. Then check the site carefully and see if it's working. If anything's "broken" at this point, let us know here so we could check the site again and help you fine-tune Asset Optimization

    8. After that's set up and confirmed, enable Page Caching in Hummingbird but don't enable SG Optimizer back.

    You should be all nicely setup at that point with all the assets optimized as much as possible and compatible cache on board.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.