issue with fixer theme

Hi I have installed the fixer theme and its not uploaded right the design has gone all over the place please can you take a look and help me as I want to edit this for my new company.

The site isnt as it looks in the builder

  • Predrag Dubajic

    Hey Danniel,

    Hope you're doing well today :slight_smile:

    I see some console errors on your site, most likely due to server configuration.
    Could you try adding below line of code inside your wp-config.php just above /* That's all, stop editing! Happy blogging. */ line:
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    Also, could you try adding this rule to your .htaccess file:

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    If none of the above solutions work can you get in touch with your hosting provider and ask them to check server logs to see if there's anything blocking AJAX requests on your site?

    Let us know how it goes :slight_smile:

    Best regards,
    Predrag

  • Milan

    Hello danniel ,

    Hope you are well today and won't mind me chiming here. :slight_smile:

    Would you please grant me support staff access so that I can check in depth regarding your issue ?. You can grant me support access via WPMU DEV > Support > Support Access > Grant Access.

    Furthermore, please also enable debug mode to your site. Please follow these steps to enable debug mode to your site.

    #1) Open wp-config.php file,
    #2) Replace this line of code,

    define ( "WP_DEBUG", false );

    with this one,

    define ( "WP_DEBUG", true );

    Let me know once you make these changes.
    Best Regards,
    Milan

  • Adam Czajczyk

    Hello danniel!

    It seems that some part of the Milan's recent post got "cut out". I'm sorry for that.

    Milan asked you to enable WordPress debugging and thank you for doing this. Now, when it's active, please try accessing your site and then download the "/wp-content/debug.log" file from your server, rename it to "debug.txt" file and attach to you response here.

    It will let us look into that file and hopefully information included in it will help us diagnose the issue.

    That being said however, I'm not sure whether it is necessary. I visited your site both as a visitor and as a logged in user (using support access that you granted) and it looks like a fresh Fixer theme install - just like the default one, not customized yet. Does this mean that you managed to solve the issue meanwhile or am I missing something here?

    If I'm missing anything, can you please upload an example screenshot illustrating the issue?

    Best regards,
    Adam

  • Predrag Dubajic

    Hi Danniel,

    Can you please replace Milan's code in wp-config.php with this one :

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Try saving changes in Upfront and this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    If the file is still not there after that it means no WP errors are happening so there's something else causing it.

    I see that there's still some admin-ajax.php console errors when starting UF editor and that could be what's causing this.
    It would mean a lot if you could get in touch with your hosting provider so they can check server logs and see if there's anything else blocking AJAX requests.
    Can you please do that that and let us know of their response?

    Also, are you unable to save the changes even with all the plugins disabled?

    Best regards,
    Predrag

  • danniel

    Hi there is no erros thats right. It doesnt come up with any errors and looks like its saving but doesnt.

    Ive read this also?

    Howdy ixpubs

    Wow excellent research skills. Yup .. you'd need to turn of mod_security for this site. There are other ways but the htaccess one is the simplest.

    This is primarily because upfront is radically different compared to other themes/frameworks out there

    Cheers
    Jude

    Could this have something to do with it?

  • danniel

    or would this work from what ive read?

    After talking with the head of our Upfront team, I've got some more information on the situation with Fixer:

    The issue with saving Fixer's homepage using the Upfront editor happens on sites with NGINX servers caused by the complex size of Fixer homepage. This is due to how Upfront 1.0 saves the layout and is considered as "too large" by NGINX's default settings.
    Changing the way Upfront saves the layout would require significant work (we're talking the level of a major release), therefore we couldn't achieve such a change in the near future.
    Meanwhile, there are possible temporary solutions for this:
    #1: If you can adjust the NGNIX configuration, you'd want to try increasing the value for the "client_max_body_size" variable.
    #2: Increase the values for "upload_max_filesize" and "post_max_size", either by altering your server's PHP configuration, or setting up a custom php.ini in your site's folder, in the event that altering the main PHP configuration is not an option.
    As far as we could test, Apache servers are not affected by this.

  • Predrag Dubajic

    Hi Danniel,

    About this part:

    Wow excellent research skills. Yup .. you'd need to turn of mod_security for this site. There are other ways but the htaccess one is the simplest.

    This is actually what I was going for with my first comment in this thread where I asked you to add the rule to .htaccess file, this disables one mod_security rule that's usually causes that issues but not in 100% of cases.
    That's why I later asked you to ask your hosting provider to check server logs, that can tell us what other mod_security rules are blocking AJAX execution on your site.

    Fixer does indeed require larger post size but based on the console errors on your site I don't think that's the case, however it's worth giving it a try so could you try adding this code to your wp-config.php and see if it works after that:
    @ini_set( 'post_max_size', '256M');

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Danniel!

    Thank you for sharing the debug.log with us.

    The error that shows up there indicates that there's not enough memory assigned to WordPress and one of the Upfront libraries is causing WP to hit the limit which in turn is causing the script to break.

    This should be fixed by increasing WP memory and to do this, please add following line to the "wp-config.php" file of your site:

    define('WP_MEMORY_LIMIT','256M');

    Make sure please that this line is added above the "/* That's all, stop editing!*/" line, otherwise it will cause other errors. Once that line is added there, please clear your site's cache (if there's any caching there) and give it another try.

    Let me know how that worked for you, please.

    Best regards,
    Adam

  • Dimitris

    Hey there danniel,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Let's check what have been done by now (please do correct me if there's something haven't been implemented until now):

    1. Memory limit raised to 256M (wp-config.php file)
    define('WP_MEMORY_LIMIT','256M');
    More about increasing memory limit can be found here https://premium.wpmudev.org/blog/increase-memory-limit/
    You can even raise that to 512M to be sure that there won't be any memory leaks
    define('WP_MEMORY_LIMIT','512M');

    2. Disable mod_security (.htaccess file)

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    Previous rule can be extended to

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    SecFilterRemove 00318
    </IfModule>

    but yet again, you should contact your hosting provider to double check that these settings don't get overridden by other server settings that you can't actually control.

    3. All UF dependencies are safely loaded by defining it in wp-config.php file
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    4. Debug log is successfully created (WP_DEBUG) just in case to get any related errors (wp-config.php file) https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Having said that, could you please confirm that all these steps have been made?
    A confirmation about point #2 from your hosting company would be perfect too! :slight_smile:

    I decide to delete fixer and install one of your other themes that all worked! So installed fixed again tried and still not saving!!!

    Is there any errors generated now in /wp-content/debug.log file? Please advise!

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.