Issue with hummingbird Apache Cache

I got this from hummingbird for that client.

Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

Hosting is on Godaddy. I VPS Server.

  • James Morris

    Hello Yann,

    I hope you are well today.

    Could you try adding the following to your .htaccess file manually and recheck?

    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>

    Best regards,

    James Morris

  • James Morris

    Hello Yann,

    I hope you are well today. It sounds like this is a hosting configuration issue.

    In order to help you better with your issue, would you please grant me access to your site/server?

    Please visit the Contact page and complete the form with the following information:

    Select "I have a different question" from the drop-down box.

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    - link back to this thread for reference
    - any other relevant urls

    Best regards,

    James Morris

  • James Morris

    Hello Yann,

    I hope you are well today.

    Yes, I was able to login to your site via the Support Staff Login, but that access did not give me enough information to thoroughly troubleshoot the issues you are having.

    I've found a number of problems that are contributing to your site's poor performance.

    * Your current PHP version is 5.4.x
    * Your current WordPress version is 4.4.x
    * mod_deflate was not enabled (it is now!)
    * Some of your custom code referring to mailnetwork-r11 is causing erorrs
    * Some of your plugins are causing a large number of debug.log messages (see: wp-content/debug.log)
    * Your server is taking an excessive amount of time (8.40 seconds) to respond
    See: https://tools.pingdom.com/#!/bgIZ5a/https://mailnetwork.com/

    You may want to contact your hosting provider and ask them why your server is taking so long to respond.

    I was able to verify that gzip is indeed enabled and functioning using Pingdom and https://varvy.com/tools/gzip/. Several other tools timed out trying to connect.

    My recommendation is to upgrade your server configuration to run PHP 5.6.x as it is the current/stable version of PHP. You'll also want to update WordPress to the latest stable version as there are many security fixes since your current version.

    Once you've done the above, please then retry enabling Browser Compression and Gzip Compression in Hummingbird. If this does not resolve the issue of HB reporting that Gzip is not enabled (and it is), please run a plugin conflict check to see if there are any plugins causing issues with HB running properly. You can learn more about how to perform a plugin conflict check at the following link: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know if the above resolves your problem! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.