Issue with Hummingbird files expiry time.

I have set 8 days as file expiry times in Browser caching, but JavaScript and CSS files current expiry time is stuck at 7+ days.

  • Ash
    • WordPress Hacker

    Hello Brett Gurney

    Yes, I could see the issue on your site. This could also happen if there is a restriction on the server or rule set on the server which is not overwriteable by the htaccess.

    So, would you please contact your host about this and ask them if they have any rule set on their server for the expiry of Javascript and CSS files?

    Let us know how it goes. Have a nice day!

    Cheers,

    Ash

  • Nithin
    • Support Wizard

    Hi Brett Gurney ,

    They checked it out and informed me that everything appeared to be in order. Could it be something else?

    Sorry, it’s not clear regarding what your host said. Were they able to confirm browser cache expiry is set as 7 days in the server-side? Is there a way to increase the value via the server-side?

    Such an issue is common when the server rules are overriding the rules set by the Hummingbird browser cache setting. I checked your website via the FTP side, and don’t see anything in specific which could cause other than server overriding the browser cache value.

    Is it a major thing if the setting is on 7 days instead of 8?

    Google recommends a minimum 8 days or greater when it comes to browser caching. Since you are using Hummingbird CDN it sets a cache policy of 30 days automatically, so it shouldn’t be a major issue when you have Hummingbird CDN enabled.

    I checked your website via Google Page Speed Insights, and I don’t see any issues pointed regarding browser caching at the moment since Hummingbird CDN is enabled:
    https://developers.google.com/speed/pagespeed/insights/

    If you still want us to check further and set the remaining as 8 days, then please check with the hosting provider whether they could increase 7 to 8 days? Or you could share cPanel login with us so that we could double-check if there are any settings regarding this is cPanel side or not too.

    Since the ticket is public, and if you want to share the cPanel login, you can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -cPanel credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up on the ticket once you have sent the above credentials. Have a nice day.

    Kind Regards,
    Nithin

  • Brett Gurney
    • New Recruit

    thanks Nithin … I probably didn’t ask them the question properly so I went back to them to try again and this time i guess I made more sense lol
    Their reply was this ….

    Hi Brett,

    It seems static resources are kept in the cache and are re-validated every 7 days.

    Could, please, tell me which site is in question so I can increase it to 8 days as requested.

    Let me know if you have any follow-up questions or need our help with any other troubling technical issues there.

    Warm regards,
    Milen T.
    WPX Hosting Support

    and then this …

    Hi Brett,

    Thank you for the update.

    The increase has been done to 8 days.

    Let me know if you have any follow-up questions or need our help with any other troubling technical issues there.

    Warm regards,
    Milen T.
    WPX Hosting Support

    So i checked and yes I can see it now states 8 days instead of 7 …. so I guess it’s fixed.

    Thanks again for your help. I’m new and learning

    Cheers
    BG

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.