Issue with Images not loading after using Smush Pro

On both my registered sites (dni-makeup.com and academiazeusronda.es) my images (mostly thumbnails) have stopped loading after smush pro has been set up. They worked for a few days and now they are gone. They just never end up loading. Tried on several computers and browsers. On Academia Zeus you can see it on the home page as images there won't load in the course list. On DNI-Makeup you can either see it on the home page under the categories or also within categories with few products also the product image on product page won't show: https://www.dni-makeup.com/maquillaje-lifting-resolutive/
The websites are also on different hostings so it's not a server related issue.
Thanks!

  • Adam Czajczyk

    Hello Luna

    I hope you're well today and thank you for your question!

    I checked both sites mentioned in your post and on "dni-makup" I don't see any images missing. It looks like they all are there. Did you manage to solve that or you still see them missing? If you do, could you please share a screenshot showing that with me? It would help me in checking the site again.

    On "Academia Zeus Ronda" I can see the issue. The problem seems to be with some of the images only and I'm afraid that's related to the fact that you're also using ShortPixel plugin for optimization. Is there also Autoptimize plugin installed?

    If yes, you would want to disable any image optimzation options there so 1) there'd be no attempts to "double-optimize" images and 2) images wouldn't be offloaded to ShortPixel CDN as they currently are.

    Smush Pro plugin only supports offload to Amazon S3 (and soon to our own CDN as well), provided that there's S3 Offload plugin installed. It doesn't support any other offloads though.

    Disabling that optimization as mentioned above should fix the problem. If it doesn't help, would you please grant me a support access to your site so I could check its configuration? To do so, please go to the "WPMU DEV -> Support" page in site's back-end and click on "Grant support access" button, then let me know.

    Best regards,
    Adam

  • Luna

    Hi Adam!

    Thank you so so much for your prompt reply!
    We don't use any plugin called ShortPixel, but we did have Autoptimize. I have now disabled it but the issue continues. I have granted you support access now to Academia Zeus.

    Re DNI Make Up, I still encounter the same issue, attached is a couple screenshots of the issue. I also activated support on DNI Make Up.

    Thank you so much!
    Luna

  • Adam Czajczyk

    Hi Luna

    Thank you for your response.

    It's possible that Autoptimze is just using shortpixel CDN "on its own" for image optimization. After you disabled it I checked the site and there were no more references to it so I think that's the case.

    However, since Autoptimize was also doing asset (CSS, JS) optimization and caching while there was also Hummingbird doing the same, disabling Autoptimize was a good step in addition you'd need to clear Hummingbird's cache. I know that Page Caching is disabled there but there is still internal cache for Asset Optimization.

    I went to "Hummingbird -> Dashboard" page and used "Clear cache" button there and the missing images seems to be showing fine now. Would you please check the site to see if all are back now or there are still some missing? If there's still something to be fixed/adjusted regarding this, let me know please.

    As for the DNI Make Up site. Do you also have Autoptimize and Hummingbird there? If so, try doing exactly what was done here: disabling Autoptimize and then clearing HB cache the way I described above + any other caches on site/server if there are such. If that doesn't help or is not a case, would you please enable support access to it as well so I could take a closer look?

    Best regards,
    Adam

  • Adam Czajczyk

    Hi Luna

    Thank you for letting me know.

    It seems that the issue got back indeed. I checked the site again, looking into configuration and I think it's still related to a sort of "over optimization". When I looked "deeper" I found out that in addition to already disabled Autoptimze there seem to be more "optimization" tools/features that seemingly overlap.

    One of those is lazy load that is actually a part of the theme while there was also an additional plugin for that. I realize that the plugin gives a nice "spinner effect" and seems to have more options than theme itself (regarding lazy load) but it's possible that there are some parts of that feature conflicting in terms of code. Then, Hummingbird is used to optimize assets but I'm not sure about the theme and some other plugins, it seems that there might be some additional optimization routines built into them. It's a bit difficult to diagnose "out of the box" as I don't want to risk to big changes in site configuration at once.

    For now, I disabled lazy load in a3 lazy load plugin and after clearing HB cache again, it seems to be working again. This time I checked as a logged in user with Chrome that I used before but also in a regular and incognito modes in Firefox (as a visitor) that I never used to visit this site. I also browsed through various pages on site (Academia Zeus) and it looks like it's working now. Could you check again (just make sure that you cleared browser cache or use incognito window), then wait for a while and check again if the issue gets back or not?

    I'm pretty sure that this is not really related to the Smush Pro itself but rather all these "optimization/performance" options and tools so we'll need to eliminate/re-configure them step by step if necessary until the issue is "persistently solved".

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.