Issue with migrating a website

Hi

My client has a website http://goo.gl/UuAnuM, I have backed up this website and imported the backup to my demo website http://goo.gl/GbLsJ1 using this plug in https://goo.gl/QyO5aa with unlimited export and import capabilities, in order to perform some plug in updates without affecting my clients website should any issues arise, once this has been done without issues on the demo website I was then going to export the good website over to the new hosting provider.

Before updating any plug ins I have found that the website (imported) to http://goo.gl/GbLsJ1 (demo website)does not display the same as http://goo.gl/UuAnuM (client website).

According to the backup plug in provider(I have support from them which is paid for but after 2 weeks of going back and to and then they actually broke my clients website, I am left to deal with it alone) there is an issue with the themes Visual editor and the backup actually did work? (I paid for this theme but the support has since run out so I cannot ask them).

I have enabled support on the demo website http://goo.gl/GbLsJ1 and would really appreciate your urgent help. If you could please compare the two websites you will see what the display issues are.

http://prntscr.com/bapxdy client website displays icon's on home page
http://prntscr.com/bapxrt demo website does not display icon's on home page
http://prntscr.com/bapyoe mega menu displays correctly on client website
http://prntscr.com/bapz3e mega menu does not display correctly on demo website
Thanks
Joanne

  • Ivan Shulev
    • The Bug Hunter

    Hey Joanne ,

    I hope you are having a nice day so far!

    I see that the icons are displayed on the demo site, as well as the mega menu, when you hover over the parent element.

    I assume it is due to the missing CSS. I get the following error on the demo site:

    Failed to load resource: the server responded with a status of 403 (Forbidden)
    jquery-migrate.min.js?ver=1.4.0:2 JQMIGRATE: Migrate is installed, version 1.4.0

    This can be fixed by changing folder (or individual file) permissions on the demo server.

    If you are uncertain, please contact your hosting provider. The 403 error code, means forbidden file.

    I hope this helps and I wish you an awesome day ahead!

    Ivan

  • Joanne
    • The Incredible Code Injector

    Hi Ivan

    Thank you for your fast reply.

    I know how to change permissions, what permissions would I need to change and what would the permission code need to be please?

    Also, can you see the icons on the demo website? and where do you see this error please?

    Thanks
    Joanne

  • Joanne
    • The Incredible Code Injector

    Hi Rupok

    This is what the hosting company said, wasn't much help I am afraid.

    "The error could mean a lot, it could mean one of the folders above that file is not 755 or possibly you have something written in your .htaccess to now allow the viewing of php files in specific directories or many other things."

    Any thoughts please?

    Thanks
    Joanne

  • placidsolace
    • Design Lord, Child of Thor

    Are you able to tell if the back up brings over all settings within the old .htaccess? If not then manually confirm this. Is the hosting of both the old site and demo site on the same provider? Perhaps there is something built differently from one to the next. Also, I'd strongly urge you to use the amazing Snapshot Pro plugin from within the WPMU DEV family, I do this all the time for clients and it works great.

  • Joanne
    • The Incredible Code Injector

    Hi

    I'm not sure how to check if the old. htaccess has been brought over from the old website, the old site is a different hosting company to the demo website, I just tried to install snapshot pro but I am now experiencing issues with ftp access so am trying to resolve that with the hosting company.

  • placidsolace
    • Design Lord, Child of Thor

    In cPanel, go to your file manager, then the root of the Public HTML or WWW folders. From there make sure you have hidden files visible, and then use the code editor to open the .htaccess file.

    This might help to at least see the file if its not there at default:
    http://www.inmotionhosting.com/support/website/file-manager/show-hidden-files-in-file-manager

    If you do not have cPanel with your hosting then I am not sure how to advise you. But this does sound to be more of a hosting issue, considering the mention of permissions, different hosts, etc. If you are a reseller or have a private server solution I'd advise quickly rebuilding the new site as that is the one not showing the icons. This could be as simple as something went wrong during installation/setup that is manifesting when doing the site restore.

    Additionally, have you tried temporarily disabling Mod Rewrite to see if that can help? That has caused me many issues with certain hosts and the different configurations of .htaccess and permissions.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.