Issue with page caching

Hi. I have a problem with hummingbird. I’ve spoken with support two times but with no result. If I activate case module the plugin shows to non logged users the mobile site views.
If I clear the cache with button happens the opposite: site is ok in desktop mode for all users but the mobile view stop to work (maybe conflict with wptouch pro?).
The only solution i’ve found is to deactivate page cashing but it slow down website as you can see in page speed or gmetrix.
I tried to deactivate hummingbird from the compatibility panel of wptouch but it does not work. What can we do?

  • viobru
    • Recruit

    Hi, Fabio!

    Hope you are doing great :slight_smile:

    I was checking this and instead of deactivating Hummingbird from WP Touch I would suggest to exclude mobile devices from Page Caching in Hummingbird. You can do this by excluding User Agent strings under Hummingbird Pro > Caching > Page Caching > Exclusions:
    You can find a list of the most common User Agents at Device Atlas, and you can also check some suggestions on this ticket from another member that had a similar issue.

    Actually, there is a feature request ticket opened for a "one-click" solution for this, you can vote for it here.

    Hope this helps and please let us know if you have further questions regarding this.

    Kind regards,
    Violeta

  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hi Fabio and sorry for the late reply.

    Unfortunately there isn't a "quick" way let's say for the time being to fix this. The only way would be to exclude the User Agents as viobru mentioned in her reply.

    Let me explain 'why' this happens though so you can have a little bit more in depth view: the WP Touch plugin actually completely 'removes' the Theme and adds it's own. This is why the website while in 'desktop' viewports is loading assets from wp-content/themes/your-theme and on mobile from /plugins/wptouch .

    Since there are now basically '2' different themes the browser only knows 1 asset to load each time when a page is Cached. This is why if you enable Caching and load the 'mobile' view then you always see the mobile version as that theme is actually cached and vise versa if you open the desktop version first then that Theme is always serving it's assets.

    We already have a featured request as mentioned previously about disabling caching on mobile devices so I've informed our Developers about this specific issue as well to keep in mind for future reference.

    Unfortunately again, there's nothing we can do about this at the moment since the way desktop/mobile version are handled with 2 different themes is not the most optimal or easy to tackle.

    Regards,
    Konstantinos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.