Issue with signup password

Hi,

I searched the forums an found that this has been noted before, but not resolved as the issue wasn’t clearly elaborated.

With signup-password plugin, if there is an error on any field validation, the passwords are set to blank.

This applies, even if the error is on the second screen (i.e. when setting the site name, if you put in uppercase you correctly get a validation error). In this case, the second screen is redisplayed with the error message and ‘secretly’ the passwords are reset to blank.

When the user corrects the error on the second part sign-up screen the blog gets created. The fact that the password was reset to blank, even though they were correctly provided on screen 1, a random password gets generated.

Obviously not what the user expected.

Looking forward to a fast fix on this one as this is happening lots.

  • aecnu
    • WP Unicorn

    Greetings ROIBOT,

    Thank you for bringing this significant issue to our attention with your detailed description of what is going on, it is certainly appreciated.

    I would venture to say that this particular issue, which I have seen all over the internet regardless of it being a WordPress site or not, ids caused by the screen refreshing from the error and the originally input password not being cookied for obvious security reasons.

    However, I am certainly not the lead developer and I am not sure if this is indeed the intended outcome.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.