Issue with the events - Unsure whats causing the issue

Hi Guys,

Sorry to be a pain but looking to see if you send me in the right direction again. I believe you still have remote access enabled for five days. The good news is the events individual pages work just perfect now but seems the be the event archives, just does not want to play ball with me.

I have an addon on site called Live composer in which helps me to live edit the front pages, but its like the templates not there, so I disabled it and the page just displays a blank page.

I've tried adding short codes to try and display an archives for the events page but nothing shows, or even when I do try overriding, it just displays like this or the other option of the massive sized calandar which is bit of an eyesore for the website.

Even when live composer is disabled, there seems to be still not option to edit the page, don't know why i only get this with the events page and no other pages....hmm!?

Any light shed on this, would be much appriciated

    Dimitris

    Hey there Bridget Kelly,

    hope you're doing good and thanks for reaching us!

    I just inspected your website and I can see that you're overriding the Events+ templates.

    Could you please share with us your custom template files? Simply rename these to .txt files and attach them here in your next reply.

    I also tried to navigate to /events/ page (as the main root slug for events set in Events -> Settings -> Plugin Settings) but I was getting a HTTP error code 500. As this is a pretty generic error message, could you please access your server via FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error by visiting the /events/ page and getting the error-500 message once more. By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply. If size of text file exceeds the 5MB limit of our forums, please use a service like Dropbox and post the shareable link instead.

    Warm regards,
    Dimitris

    Bridget Kelly

    Hi Dimitris,

    Many thanks for coming back to me. I got it enabled but I can't seem to find anything actually in the error log relating to the events page apart from a dogey sidebar. I've also disabled now buddypress sidebars plugin to see if it made any difference. What I've done is put everything in dropbox, all the logs as well as the complete theme to see if this will help

    https://www.dropbox.com/sh/vjlidlq2fkno12x/AAB3mje7CMImREyQFH35WsJ3a?dl=0

    Adam Czajczyk

    Hello Bridget Kelly!

    I checked your site and the first issue that had to be solved was the events "root slug" on "Events -> Settings -> Plugin Settings" page. It was set to /EVENTS and for some reason your server seems to recognize the difference between uppercase/lowercase characters. Usually that doesn't matter but in this case server seems to see that and was directing you to a non-existent page, causing an error.

    I have set that root slug back to "/events" and the events archive page and on "Events > Settings -> Appearance settings" page I switched off the "Override default appearance" option. Now the page loads and it actually works as it should.

    The issue however is that it does say that "No event found". That's because there's no events in current month and the default archive is "monthly". To overcome this I have enabled the "Default to all Events" add-on on "Events -> Settings -> Add-ons" page and it now should be showing all the events.

    I'm not sure how that will work with LiveComposer though but give it a try please and let me know if you're now able to edit the page.

    Best regards,
    Adam

    Bridget Kelly

    Hi Adam,

    Sorry, didn't you replied on Saturday, my bad! I've just taken a look and its almost perfect, I know its a bit fidgety and also can't seem to edit the page, which is a tad annoying since the sidebar needs to be replaced but I'll look into this.

    I just wondered, does the events plugin at all display like the plugin Events Manager as I was under the presumption that it would display like this?#

    If you look at the images, one is events manager pro and the other one is events by wpmudev.

    Dimitris

    Hey there Bridget Kelly,

    hope you're doing good today!

    It seems that /events/ page is using the Sidebar Widget Area. You should be able to replace this using a Custom Sidebar for events archive pages though.

    As for templating, you can use the templates coming from plugin or from your theme by activating the following options in Events -> Settings -> Appearance settings:
    - Override default appearance?
    - Archive template

    I just switched quickly these options and there isn't indeed any that matches the one from Events Manager plugin. I think the closest one is the default list view that you've shared and I can help with any CSS styling if needed. As for filters, there isn't such functionality in Events+ implemented already, so this should be custom made. For any kind of custom work, you can advise our Jobs & Pros section (no WPMUDEV staff members included there).

    Hope that was some help, let me know if further assistance is required here!
    Take care,
    Dimitris