Issue with the new version of Domain Mapping

Hi Guys,

Since we updated the domain mapping plugin on this site, we're having major issues with being redirected to https when trying to access wp-admin.

The problem is that this server is not configured for SSL, so when we try and carry out an action that redirects us to SSL (post, trash post, activate/deactivate plugins, etc) then we're sent to a 404 page.

It's made the entire network unusable.

I have provided it's domain mapping by disabling it, although this has the undesired effect of taking all the sites that run off it down at the same time.

What do you propose as a solution?

Thanks!

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi, bigspring!

    If I understand correctly, when you've got Domain Mapping active, it's trying to force HTTPS on your URLs, even though you are not equipped for HTTPS, as you don't have SSL protection, correct?

    There are a few settings in Domain Mapping which will "force" HTTPS, before you deactivated it, did you check your settings to make sure you weren't telling it to use HTTPS? An update shouldn't have changed your settings, so that's something to keep an eye on, but turn Domain Mapping back on and give the settings page another look, just to make sure the wrong box wasn't ticked.

    Thanks!

  • bigspring
    • Design Lord, Child of Thor

    I'm afraid it's not that simple :slight_smile: The problem is that when the plugin is enabled, I'm not able to visit the Network Settings or Plugin Settings pages as I'm sent to https. So I can't turn off whatever setting is causing this.

    FYI - We definitely didn't change any settings, it just started to do it after the upgrade.

    I'm comfortable with MySQL and PHP though, so if there is a way I can disable it through code or the database then I'm happy to do this too.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Well that is a pickle, isn't it? That sounds like no fun at all.

    Fortunately, it will be simple to dump the settings from the DB, especially if you're comfortable with MySQL. Vaughan lays out the search terms you need in this post: https://premium.wpmudev.org/forums/topic/domain-mapping-plugin-settings-in-database#post-786804, and the member he was helping explains the changes they made to a table value to solve an issue akin to yours in the subsequent replies.

    Hope this gets it!

  • bigspring
    • Design Lord, Child of Thor

    It looks like this issue has come back with the last update we carried out on Wednesday/Thursday last week.

    Now when trying to save / trash / update a post, we are redirected to https again and get the same error.

    I can see the force SSL setting is set to false though. Any ideas what else could cause it?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.