Issues after upgrading to Membership 3.0.1

I have just upgraded from Membership 2.1.4 to 3.0.1 and I have several issues

1. Some images do not appear within protected content (shortcodes)
2. Some of the shortcode do not work properly and show up to wrong levels.

I will appreciate a quick reply since this is a live site.

Thanks

  • sourcev
    • Site Builder, Child of Zeus

    Item 1 solved!

    I still have an issue with a shortcode that supposed to protect certain content from guests, but show up for all member.

    I created a [members] shortcode and unchecked it in the positive rules of the guest access level. It worked fine until I upgraded to version 3.

    Any suggestions?

  • aecnu
    • WP Unicorn

    Greetings sourcev,

    Sorry for the delay, Friday afternoons and the weekends support is not near as robust as when the full team is active during the week.

    Wow that is quite a jump in versions.

    I am happy to hear that you have managed to get the images issue worked out.

    By any chance with the new version activated have you deleted the [members] shortcode from the custom shortcodes and added it in again (I do not mean deleting it form the protected content areas)?

    Please advise.

    Cheers, Joe

  • sourcev
    • Site Builder, Child of Zeus

    No. I have not deleted any of the prior configuration before or after the upgrade. I can see all these shortcodes under Memebership->Options-> Content protection. (see attached screenshot.

    I also verified that the shortcode is selected to appear in the specific access-level positive rules. All seems to be set correctly.

    It's not only the [member] shortocode that does not work, all the content-protecting shortcodes I have created in the previous version do not work. I had to replace those shortcodes with the new automatically create one's.

    As a matter of fact I can't even find where I can add new shortcodes.

  • aecnu
    • WP Unicorn

    Greetings sourcev,

    My apologies and mistake regarding the creation of custom shortcodes within the Membership plugin.

    Sometimes this happens with cross ticket thoughts while processing 50-75 tickets every single day Monday through Sunday.

    I had to replace those shortcodes with the new automatically create one's.

    Then am I to understand that you have resolved your issues with the new shortcodes and that everything is working correctly after you had to replace all the previous shortcodes with the new ones?

    Please advise.

    Cheers, Joe

  • sourcev
    • Site Builder, Child of Zeus

    Hi Joe,

    I have resolved the issues partially.

    When it come to shortcode that only protect a specific level, the replacement of the shortcode resolved the issue. However when it come to shortcode, which I have created in the previous version to protect several levels at the same time (in my case is content that I would like to be visible to all access levels), or in other word to anyone other than guests, I had to find a workaround, which I did not really like. In essence I had to duplicate the same content for each and every access level, with the exception of guests. It worked but it is an "ugly solution".

    I wonder if there is a better and more elegant solution for these cases.

  • aecnu
    • WP Unicorn

    Greetings sourcev,

    I totally agree that this is not a good solution and I shall ask the lead developer with his invaluable insight into this plugin if he would come in here to possibly advise/advice us as to a better possibility or way to do things with hopefully not having the need to duplicate content.

    I do see where this may possibly be necessary to prevent cross leveling, but I am certainly not the resident expert of this plugin.

    Though this may take longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings sourcev,

    I have in fact requested the lead developer on Membership plugin to come in here with his invaluable insight and possibly offer us some advice/advise on hopefully a better way to do this.

    One would think it would be hierarchical, if marked level 1 access - level 2 would have access to that content too.

    However, it is certainly best to hear it from the expert and see what his thoughts to this are.

    Thank you for your patience.

    Cheers, Joe

  • sourcev
    • Site Builder, Child of Zeus

    I continue to have difficulties with the new version, even after upgrading to version 3.0.2

    In fact some new issues appeared after the upgrade, such as, that the plugin recognize some links in the URL group and doe not recoginise other links in the same group and therefore redirect the user to the "Members only" page.

  • sourcev
    • Site Builder, Child of Zeus

    Hi Barry,

    I have discovered that this issue is not related to the URL group, but rather more stranger issue.

    Since this is only happening to me on Firefox I am still testing to see if I can reproduce the same issue on another computer / OS, to determine if this is an OS or browser issue, or even maybe just a local issue on my computer.

    I will let you know in case the issue is the former rather than he latter.

  • sourcev
    • Site Builder, Child of Zeus

    Hi PC and Barry

    Sorry for the delay.

    I tested in Chrome and Firefox, both in Windows and Linux and it happens only on Firefox (13.0).

    Here is what happens:
    1. I am logging into the system as one of the members.
    2. At some point after logging in, while navigating the site, I get "no access" page warning. This always happens while navigating to the same page.
    3. I am still logged in, but when I check the member list, in the admin section, I see that this certain member was unsubscribed somehow and is not part of any subscription or level any more.

    I tried this several times with several users and the same thing happens. After visiting that specific page, the member is being unsubscribed somehow from their subscription and level.

    I can't imagine what could be causing this.

    Note: This problem only appeared after I upgraded to version 3+

  • aecnu
    • WP Unicorn

    Greetings sourcev,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.