Issues setting days and hours as the settings do not appear to be responding correctly

Hi. I have Wordpress installed locally. I am using a theme forest site called Namo. I have installed the appointments+ plugin and gone through the settings and entered the shortcode to a page. The calendar does appear. I have set up a service and a user and they also appear on the page.

The problem is that some date and availability changes happen but some do not. For example, what ever changes I make to the times on a Monday, it remains blocked out as "Busy", even when the the setting are the same as other available days. If I make a Sunday available it becomes available.

I am also having trouble setting up the times of appointments. It seems impossible as I get random results. Basically the service is available from Monday to Friday. Each session is 1hr 30 min, there is one at 11am, then an hours break and 2 sessions back to back which start after the break at 1.30pm. Please give any advice on the settings required and confirm that this should be possible to set up.

I have refreshed the cache (ticked the box) and chosen to have the cache in Wordpress, I have tried those setting always in case they were having some effect. I have trashed the plugin and re-uploaded it and activated it to try again.

Thank you and I look forward to your help and advice.

Kind regards

Mark

  • Vinod Dalvi

    Hi Mark,

    Welcome to the WPMU Dev community and thanks for posting on the forum.

    The problem is that some date and availability changes happen but some do not. For example, what ever changes I make to the times on a Monday, it remains blocked out as "Busy", even when the the setting are the same as other available days. If I make a Sunday available it becomes available.

    Could you please share me the screenshot of your Appointments working hours and exceptions settings from the following path so that i can troubleshoot it?

    Admin Area -> Appointments -> Settings -> Working Hours Tab

    Admin Area -> Appointments -> Settings -> Exceptions Tab

    I am also having trouble setting up the times of appointments. It seems impossible as I get random results. Basically the service is available from Monday to Friday. Each session is 1hr 30 min, there is one at 11am, then an hours break and 2 sessions back to back which start after the break at 1.30pm. Please give any advice on the settings required and confirm that this should be possible to set up.

    Could you please tell me what you want to achieve and what you are getting currently( Share screenshot of it ) so that i can help you to achieve it?

    I have refreshed the cache (ticked the box) and chosen to have the cache in Wordpress, I have tried those setting always in case they were having some effect. I have trashed the plugin and re-uploaded it and activated it to try again.

    Set the appointment "Use Built-in Cache" to No on the following path.

    Admin Area -> Appointments -> Settings -> General Tab -> Advanced Settings

    Kind Regards,
    Vinod Dalvi

  • Mark

    Thank you for your fast response.

    I followed your instructions and I decided to have a look at an online tutorial which shows that on the "working Hours" section of the settings, there should be an end title where I can choose where the day ends and also another end section where I can choose where the break ends. Unfortunately these end choices are not available on my screen as shown in the attached screen shot.

    I have reloaded the current version of Wordpress just in case but this did not help. For your information I am using the "Namo" theme by themeforest.

    I look forward to your advice.

  • Mark

    Thank you for your fast response.

    I followed your instructions and I decided to have a look at an online tutorial which shows that on the "working Hours" section of the settings, there should be an end title where I can choose where the day ends and also another end section where I can choose where the break ends. Unfortunately these end choices are not available on my screen as shown in the attached screen shot.

    I have reloaded the current version of Wordpress just in case but this did not help. For your information I am using the "Namo" theme by themeforest.

    I look forward to your advice.

  • Vinod Dalvi

    Hi Mark,

    Thank you for your detailed reply.

    It seems this is an plugin or theme conflict issue as it's working fine on my test site using latest version of Appointments plugin.

    You can just try on your development site deactivating all other plugins and using default WordPress theme like Twenty Thirteen as displayed in the flowchart on the following page to know which theme/ plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Regards,
    Vinod Dalvi

  • Mark

    Dear Vinod,

    I turned off the plugins and it made no difference. So I changed the theme and then I was able to see the end times on the "Working hours" in the settings.

    I have messed around with the settings and what I select does not do as I imagine it should.

    I only have one service and one service provider. The service is set to 90 minutes. You will see from my attached screen grab, on Monday & Tuesday I want the first appointment to start at 11am, then when it finishes at 12.30pm I want the service provider to have a 1 hour lunch break and start the next appointment at 1.30pm, when that is finished I want him to start another appointment immedietly afterwards at 3pm which will finish at 4.30pm and that is the end of the day.

    Although I think that I have the settings correct on Monday and Tuesday it does not offer an appointment at 1.30pm or at 3pm as I would like.

    I have refreshed my browser. I have turned on and off "Use built-in Cache" and ticked clear cache and saved the page. None of these have the correct effect.

    Also it is a pain to have to move out of the template I am using to see the choices in the setting. Please let me know why this is, also please let me know if I am making a mistake in how I set the hours.

    Thank you in advance for all your help

  • Jack Kitterhing

    Hi there Mark,

    Hope you're well today! :slight_smile:

    Could you install the WPMU DEV dashboard please https://premium.wpmudev.org/project/wpmu-dev-dashboard/ ?

    You can then grant me support access via your wp-admin > WPMU DEV > support > support access and click "Grant Access".

    I can then review all your settings for this and get everything working as it should. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Mark

    Hi,

    I don't want to rant, mainly because I am usually wrong and it embarassing. It appears to me that I have been asking questions for nearly 2 weeks now to get this plugin to work. Now the site is live and I convinced the customer that this plugin is amazing, they are becoming annoyed.

    They are unable to reserve any appointments. Please please help.

    When I go to the settings page, there is still no end time options visable, so I am unable to set the break end times etc. I still have now news as to why your plugin does not work.

    Please please put it right. I build website for therapists and it would be greate if I could get the functionality your plugin offers.

    I look forward to your help.

  • Mark

    Hi Vaughan,

    Thank you. I look forward to hearing what your developer suggests.

    I am not sure if the theme developers will care about my issue, but is it possible that you contact them for me?

    Is there a way that I can run the "make an appointments" page on the website but not as part of the theme that it is having conflict issues with?

    I played around and was able to set all the timings if I was in another theme but as soon as I activate the original theme, the appointments time options freeze.

    Please let me know soon as my client is refusing to pay.

    Thank you for your help.

  • Vinod Dalvi

    Hi Mark,

    I am not sure if the theme developers will care about my issue, but is it possible that you contact them for me?

    I don't find any way to contact them as they are displaying coming soon page on their site http://www.brandexponents.com/ as displayed in the attached screenshot and the site is down.

    Is there a way that I can run the "make an appointments" page on the website but not as part of the theme that it is having conflict issues with?

    No there isn't any easy way to do it.

    You can install another WordPress on your server, activate different theme on it and use Appointments + plugins there separately but this will create syncing problem with your original WordPress install.

    Could you please send me your theme on the email id contact@wpmudev.org so that i can troubleshoot it on my test site to fix it?
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better

    Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi Mark,

    Thanks for sending me the theme.

    I followed your instructions and I decided to have a look at an online tutorial which shows that on the "working Hours" section of the settings, there should be an end title where I can choose where the day ends and also another end section where I can choose where the break ends. Unfortunately these end choices are not available on my screen as shown in the attached screen shot.

    I have tested the theme on my test site and found this issue is happening because the nano theme that you are using is adding the following CSS code in the Appointments settings page defined in the theme file namo/be-page-builder//css/be-pb-css.css which is causing to increase drop down field width.

    select {
    	width: 255px;
    }

    To resolve this issue try adding the following CSS code in your site using the following plugin.

    http://wordpress.org/plugins/add-admin-css

    #wpcontent .app-working_hours-workhour_form td select {
    		max-width: 120px;
    }

    If you don't want to use any extra plugin to do this then try adding the following code in the functions.php file of your child theme.

    <?php
    add_action('admin_head', 'my_custom_css');
    function my_custom_css() {
      echo '<style>
        #wpcontent .app-working_hours-workhour_form td select {
    		max-width: 120px;
    		}
      </style>';
    }
    ?>

    To resolve other issues i need to access admin area of your site so either regrant me support staff access or just send log in info through our secured contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better
    - Include login information (Wordpress admin info username + password )

    Regards,
    Vinod Dalvi

  • Vinod Dalvi

    Hi Mark,

    Thank you for granting us support staff access but now i can't access the appointment page http://retreatgoa.com/aquatic_bodywork/ on your site. When i try to access it, it displays 404 PAGE NOT FOUND error.

    Could you please make the page accessible so that i can troubleshoot the issue?

    Message sent by Mark through email:

    Thank you for your help. I installed the add css plugin and it worked so I could now see and change the end times on the setting page. Now the only issue is that when I click on a day or available appointment time, nothing happens. Bassically I have 3 appointments from Wednesday to Sunday (including sunday) and each appointment is 1hr 30 mins. the first starts at 11am, the next at 1.30pm and the 3rd and final appointment starts at 3pm. The reason I am telling you is because although not available the website shows the 4.30 time slot on the page and I would prefer if it is possible to remove this.

    I thank you for your continued help.

    Warm regards

    Mark

    Thanks,
    Vinod Dalvi

  • Vinod Dalvi

    Hi Mark,

    Thank you for sharing me the correct appointment page link but now your site support staff access has been revoked.

    Could you please send me your admin log in info as specified in my following reply posted previously so that i don't have to ask you about granting support staff access again and again?

    https://premium.wpmudev.org/forums/topic/issues-setting-days-and-hours-as-the-settings-do-not-appear-to-be-responding-correctly#post-734601

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.