Issues setting Homepage in Upfront

Hello!

I am trying to set up a home page, in a classic way from 'Reading' section. I build my website using upfront, but I am kinda new to it.
So the homepage, I edited right on the new template called ''Home'' which upfront given to me.
I never thought I could not access this page phisically.

Now, The homepage is automattically set (you can see it going to my webpage) but it is not physically located in Pages and I cannot get to create the same layout on a page called home, not I get this template in the list with templates, allthough in host file manager it appears as ''archive-home''.

Now what I do if I want to add keywords and optimize this page?
Where do I found it in wordpress?

  • Luís

    Hi Alexandru ,

    Hope you're doing well today!

    Homepage from Upfront is a "virtual" page and we can't access to that "phisically", it will not be shown in the Pages list and also, the homepage layout can't be accessed to be replicated in other page.

    Our developers are aware and working to improve this and may will be changed in the future releases.

    However, you can try create a new page, replicate the Homepage layout and then change your "front page" to this new page in Settings -> Reading -> A Static page.

    Now what I do if I want to add keywords and optimize this page?

    The most popular SEO plugins allows to define the meta tags specifically for the homepage. In the below example, I used our SmartCrawl plugin to show how to add the title, description and keyword tags to the homepage:

    1) After enable the Smarcrawl, go to Settings -> SmartCrawl;

    2) In Step 3: Title & Meta, you can define this tags in the "Home" section.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís