Issues settup up buddypress

Im not new to wp, but i am new to bp.

There are a bunch of plugins i can't isntall because it requires they are "only compatible with Multisite installs."

So i worked out that i need a multi table setup. The site does need multiple blogs, i thought that buddypress made the possible without the need for other plugins :stuck_out_tongue:

I followed the detailed instructions (https://premium.wpmudev.org/project/multi-db/installation/). After sturggling through various errors and working them out, I'm undone with the following one.

I basically get a bunch of these:

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/prayerwo/public_html/wp-content/scripts/move-blogs.php on line 148

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/prayerwo/public_html/wp-content/scripts/move-blogs.php on line 150

Despite all those errors, the table is showing up with positive green comments. Although when i look in all the databases using phpmyadmin, they don't have any structured columns/rows etc. Im not sure how it works, should I be alarmed at this?

I don't know what the php/mysql function "mysql_free_result" is actually for? Is this an issue that its spitting errors at me there? Its nothing fatal, just a warning. The previous queries appeared to execute.

In any case, as I mentioned, I still can't install plugins that require multiple DB's. So even if this did work, is there anythingelse I need to do for this feature to work and accept plugins that are made for it?

---------------------------------------
db-donfig.php:
---------------------------------------
define ('DB_SCALING', '4096');
add_dc_ip('myipaddresshere', 'dc1');
add_global_table('global');
add_db_server('global', 'dc1', 1, 1,'','localhost', 'prefix_global', 'usernamehere...', 'passwordhere...');
add_db_server('000', 'dc1', 1, 1,'','localhost', 'prefix_000', 'usernamehere...', 'passwordhere...');
add_db_server('001', 'dc1', 1, 1,'','localhost', 'prefix_001', 'usernamehere...', 'passwordhere...');
add_db_server('002', 'dc1', 1, 1,'','localhost', 'prefix_002', 'usernamehere...', 'passwordhere...');
add_db_server('003', 'dc1', 1, 1,'','localhost', 'prefix_003', 'usernamehere...', 'passwordhere...');

---------------------------------------
move-blogs.php:
---------------------------------------

$dbname = "dbnamehere";
$blog_table_prefix = 'wp_';
$newdb_prefix = 'dbnamehere_';

$dbhost = 'localhost';
$dbuname = 'usernamehere...';
$dbpass = 'passwordhere...';
$db_scaling = '4096';

When i added a 'or die' on lines 144,145 of move-bligs.php:

mysql_query($sql_table);
mysql_query($insert_info);

It told me that the table already existed? Confused... not sure how to fix this - whats going on?

Cheers,
Doug