Issues with latest Membership plug-in?

upon upgrading to the latest version of the membership plug-in, the viewing restrictions that had been set up have been lost. I am not the person who originally configured the plug-in and that person developed some enhancements to make it work the way we wanted (and that person is not available right now).

The site has 7 levels of ‘access’ where the first level is available to everyone and levels 2 to 7 require a membership ID/password. Membership at level 2 can see levels 1 and 2; membership at level 3 can see levels 1 to 3; etc.

Every post has a membership category assigned to them (from 1 to 7)

Now it looks like everyone can see all posts.

It appears that the Membership plugin is now ignoring access levels when displaying the main page and browsing.

If someone selects a post, rather than browsing, then the privacy for levels appears to work however selecting categories no longer prevents people from seeing all posts within that category (regardless of the post’s membership level).

I have started to disable other plug-ins which were recently updated in order to determine if there was a conflict – so far, nothing I have tried gets things back to what it was.

Is it possible to get the previous membership plug-in version so I can see if that solves the problem?

Are others having problems with this latest version of the plug-in? (or have solved what I am describing?)