Issues with shares not posting via Social Marketing clicks.

After a user pointed it out, I just confirmed that clicking the Like button in our Social Marketing Ads does not post the status update to the user's Facebook timeline. So I tried the other social network buttons... Twitter shares post to feed properly, but the number in the ad does not update. LinkedIn shares are posting updates correctly and updating total.

Can anyone else replicate these issues?

We use Social Marketing ads to run contests by revealing questions (instead of coupon codes) which users must answer with a comment on the blog post. I've updated to most recent plugin version and Facebook issue continues.

Please feel free to try it yourself at http://nutrition.tripawds.com/2012/10/18/onlynaturalpet-coupon-code-contes/

Thanks in advance for any feedback.

  • jcnjr
    • HummingBird

    Thanks for the quick replies folks.

    I'm personally dealing with limited connectivity due to hurricane Sandy right now, but the server logs indicate nothing peculiar and there is no sign of the server being down lately.

    No, we aren't running any other Facebook or twitter scripts. Has anyone tried sharing via the ad or can anyone else replicate this?

  • Ashley Keable
    • The Incredible Code Injector

    I hope everything is ok in terms of the hurricane and hope you stay safe.

    I have just tried this and works fine with posting to my wall. Here is my Profile Page so you can see it posted fine. However im not sure if you can see it as my privacy settings may not allow it.

    You might find that the member who made you aware of this may have blocked settings in his privacy that allows sites to publish on his profile.

    I think you need a few more to test it first though so why not create a fake facebook profile and give it a try.

  • jcnjr
    • HummingBird

    Hmmm... I figured this might have something to do with FB privacy settings, but I just tested it with another account and the Like did not post to the timeline even though the default for apps is set to share as "Public".

    Where exactly in the FB Privacy settings might I confirm I've got it right for showing likes/shares from website apps.

    This also wouldn't account for the Twitter share total not updating in the social ad. Hopefully others can hep test this to see if it's functioning properly...

    http://nutrition.tripawds.com/2012/10/18/onlynaturalpet-coupon-code-contes/

    Thanks for the comment Ashley, we started the Tripawds blog in late 2006 but have only been running the mu blogs since 2009. We are not yet running MultiDB, and wish now that we had implemented that early on. We never expected the growth we're seeing, but I understand adding MultiDB at this point could get tricky or cause issues.

  • aecnu
    • WP Unicorn

    Greetings jcnjr,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.