Issues with updating Domain Mapping from 4.4.0.9 to 4.4.2.4

I have 6 web hosting accounts using WP multisite. These 6 hosting site yield 24 individual websites. After updating from domain mapping 4.4.0.9 to 4.4.2.4, many of the sites, not all, have error messages at the top of the page that look like this. It seems to be prevalent on the Linux hosting vs cPanel. All hosting accounts have deditcated IP's. I have PHP 5.3, I have disable all pluging except for domain mapping, and have enable and disable the plugin and tried numerous other odds and ends. In the end, I reinstall ver 4.4.0.9 and all is in working order.

Thank you and have a great day.

Warning: parse_url(http:///wp-admin/) [function.parse-url]: Unable to parse URL in /home/content/53/3969253/html/wp-content/plugins/domain-mapping/classes/Domainmap/Utils.php on line 306

Warning: parse_url(http:///wp-admin/) [function.parse-url]: Unable to parse URL in /home/content/53/3969253/html/wp-content/plugins/domain-mapping/classes/Domainmap/Utils.php on line 306

Warning: parse_url(http:///wp-includes/) [function.parse-url]: Unable to parse URL in /home/content/53/3969253/html/wp-content/plugins/domain-mapping/classes/Domainmap/Utils.php on line 306

Warning: parse_url(http:///wp-includes/js/mediaelement/) [function.parse-url]: Unable to parse URL in /home/content/53/3969253/html/wp-content/plugins/domain-mapping/classes/Domainmap/Utils.php on line 306

Warning: parse_url(http:///wp-admin/) [function.parse-url]: Unable to parse URL in /home/content/53/3969253/html/wp-content/plugins/domain-mapping/classes/Domainmap/Utils.php on line 306

  • Rupok
    • Support Ninja

    Hi afswpmu,

    So sorry for the inconvenience you are having. To resolve this issue, can you please login to your server with any FTP application like Filezilla and go to the root directory for your multisite? Then go to "/wp-content/plugins/domain-mapping/classes/Domainmap/" directory and open the "Utils.php" file. Then go to line number: 306

    There, you will see the following line:
    $domain = parse_url( $domain , PHP_URL_HOST );
    Please replace that line with the following:
    $domain = @parse_url( $domain , PHP_URL_HOST );
    Now save the file and close.

    After this, all those errors should be gone.

    Please let us know how it goes. If this doesn't remove those errors. We will be glad to investigate further.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.