It appears that your home_url setting is trying to redirect to another domain?

While trying to activate blacklist monitor, I receive the following error.

"It appears that your home_url setting is trying to redirect to another domain. This often happens when you are forcing https but haven't updated your site setting for that. Please verify that the home_url option of your WP install is correct, then click refresh updates in the Dashboard plugin."

It's the same problem as in this topic:
https://premium.wpmudev.org/forums/topic/cant-activate-website-monitoring-due-to-home_url-error#post-1085843

Also my multisite has SSL enabled. I noticed something strange. I did what Nastia suggested in the other post. Go to Settings > Sites and then go to edit the main site.

This is what I see:
Site Address (URL) http://multi-mainsite.nl/

However if I go to tab settings, I see this:
Siteurl https://multi-mainsite.nl
Home https://multi-mainsite.nl

Also added the following code to wp-config.php, without any result.
define('FORCE_SSL_ADMIN', true);

However it's still not working. Any suggestions?
Thanks!