It gives me an error saying that the path being passed to facebook is not correct. How can I fix it?

I am unable to go to step 2 in the process of configuring the settings.

I have tried both the actual path.. https://www.essori.com/website as well as https://www.essori.com/, but it is still not working.

Is my configuration correct?

Do I need to change something?

I have installed the WP installation in a subdirectory called website. Would this be causing havoc with the plugin?

Any help would be appreciated

Regards

Jeff

PS ( will grant Support access to you)

  • Jeff

    Hi Kasia,
    Thanks for your reply, I first saw the error when I couldn't get it working, and I did a search and found that if I used Firebug in Firefox, I could watch the Firebug console and see any errors when I went to the website.
    Then I found I got the error, after I had put in the details of my App and tried to Reset Tokens.

    Thanks for the tip on the url to pass to the app, It helped be get to the next step.

    Now I have got past that by making sure my Facebook app has "Client OAuth Login" and "Web OAuth Login" Enabled, and then input my website address "https://www.essori.com/" into the "Valid OAuth redirect URIs" field. (This can be found under Settings / Advanced)

    My next question is :
    I would like it to be able to post to my "Essori" page under my Facebook account, when I create a post on my website. For some reason it it does not give me the option to.
    Do you have any ideas on how to allow this to work. I have already granted extended permissions to the app and made sure that "Prevent Access to my linked accounts" is not checked.

    (Slightly off topic but also a question perhaps for a new ticket, would be do you have have any suggestions on how to make sure that my site is reliably fast and optimised. I have tried my best but it continues to defy my efforts by being fast when I am logged into the admin console, but slow when I check the next day)

    Appreciate your help.

    Kind regards

    Jeff

  • Kasia Swiderska

    Hello Jeff,

    I would like it to be able to post to my "Essori" page under my Facebook account, when I create a post on my website. For some reason it it does not give me the option to.

    There is option on the bottom of settings for this. "Autopost to Facebook" and there is "You need to be logged into Facebook with at least basic permissions set granted to set up Autopost mappings. Click here to do so now" <- so you need to click this link.
    Then you will be able to map posts to facebook pages.

    Kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.