It looks like this plugin breaks WP3.6 -- any ideas? This

It looks like this plugin breaks WP3.6 -- any ideas? This is the error I see when activating Events+

Fatal error: Call to a member function is_main_query() on a non-object in /home/clients8/public_html/canyonaero/wp-includes/query.php on line 724