Items not sticking in shopping cart.

I have market press activated on multisite. When I add things to the cart they show up, but disappear when I check out. It is working fine on the sub-sites ex: http://kisses.iholdlovewithyou.com/store/products/
(Though there is a warning tab that shows up in the firefox browser.)
On the main install products disappear when checking out. Ex: http://divinitree.com/communitystore/products/.

  • Vaughan
    • Support/SLS MockingJay

    Hi @carlen,

    I believe this might have something to do with domain mapping, as you are using the HTTPS plugin.

    This thread (It's a long read) might give you some insight. https://premium.wpmudev.org/forums/topic/removing-domain-mapping-during-checkout-with-marketpressdomain-mapping-plugins

    I'm not sure what's causing that error, but as it's the meta title, it might have something to do with the SEO plugin you have. You can try disabling it, see if that clears the error.

    I'll also ask the developer for some feedback on this, as I can't see anything physically wrong with your settings at all, so it looks like it's a cookie related issue with domain-mapping.

    Hopefully the developer will respond shortly.

    Thanks

  • Carlen
    • Site Builder, Child of Zeus

    Hi Vaughan,

    I disabled the SEO plugin and am still having the issue. It seams like that thread was regarding using SSL certificate. I am just using the chained Paypal method at this moment with no SSL currently setup. The answer could have been in there but some of this was a little beyond my understanding. I also didn't have time to really surf through each step they talked about. Are WPMUdev Marketpress and WPMUdev Domain Mapping incompatible?

    And thanks for all you do!!
    Carlen

  • Jonathan
    • The Bug Hunter

    Hey @Carlen,

    I noticed that you are using the W3 Total Cache plugin so I added some exceptions to your cache rules. Basically, once someone adds an item to their cart we have to disable the cache. Otherwise, the cart data won't display correctly because it's always using a cached state. Here's what I added to the Reject cookies setting:

    PHPSESSID
    mp_globalcart_*

    As far as the PHP warnings. In your theme you were using a function called

    elegant_titles()

    Not sure what that function does, but I replaced with

    wp_title('')

    which is the core WP function for generating titles and what the WordPress SEO plugin requires to generate the title correctly. I then re-enabled the WordPress SEO plugin and that seemed to fix it.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.