items on mapped domain disappearing from cart on multisite

I add a product to my cart on my mapped domain, it goes in my cart, I click checkout (global cart on multisite) and it tells me my cart is empty.

I believe this is a cookies issue – please help!

  • Tyler Postle
    • CGO

    Hey there Lindsay,

    Hope you’re doing well today and thanks for your question!

    Can you go to:

    Network admin > Settings > Domain Mapping. Then set “Administration mapping” to “Domain entered by user”.

    The reason we need to make changes to the admin side mapping for the cart is because the cart uses ajax from wp-admin.

    After you have set that up check the cart out again and see if it’s working properly :slight_smile:

    Also, the support staff access has an invalid token, if you’re still experiencing issues after the above solution then if you could revoke and regrant access that would be awesome!

    Hope this helps.

    All the best,

    Tyler

  • DavidM
    • DEV MAN’s Mascot

    Hi @lindsay,

    Thanks for your patience here! Working alongside Tyler, I’ve tried out something with the checkout myself though I hope you won’t mind my discussing that more with you via email.

    I’ll send that along shortly and will see how we can get that sorted asap!

    Meanwhile, any questions you might have, just let us know. We’ll be happy to help. :slight_smile:

    Cheers,

    David

  • DavidM
    • DEV MAN’s Mascot

    Hi @lindsay,

    I just wanted to post an update really quickly after having emailed you but in this case, as you’re using the global cart feature, there’s an issue with the mapped domains due to cross-domain security concerns.

    Could I ask if it’d be feasible for you to not use the global cart for now?

    The developers are still looking at ways to handle this, though for now the global cart wouldn’t work across domains.

    Looking forward to your reply!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.