I've bought

hi,

I've bought the wpmudev today specifically to help my boost my site speed. I've set the smush pro & hummingbird plugin but don't see any significant improvement...

please let me know when we can review the site to make sure I've set it right.

Thanks,
Evyatar

  • Sajid

    Hello Evyatar Sagie,
    Hope you are doing good today and very warm welcome to WPMU DEV :slight_smile:

    Lets start with Hummingbird plugin. After installing this plugin, first thing you need to do is run performance test for recommendations.

    Please follow the recommendations and enable the requested plugins or modules of the plugins and configure that up.

    Yes, you would have to install WP Smush Pro plugin and bulk smush all images. That will definitely increase the site speed.

    We have written a detailed plugin on how to increase the site speed and boost the performance, that will surely help you set it up nicely.
    https://premium.wpmudev.org/blog/hummingbird/

    One of most important (and difficult) configuration is minification while working on site performance. Please read this blog post to configure it correctly:
    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    If you still need help with any thing else, then please don't hesitate to ask and enable support staff access to so I could take a look if needed.

    To grant access go to WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Evyatar Sagie

    Hi Sajid,

    Here are a few examples:
    1. i've set the super smush feature but i still get this alert in google speed test:
    Inline image 1

    when running it on this link - https://www.next-insurance.com/yoga-insurance/

    2. i get this one as well -
    Inline image 2

    3. i get this alert on the pixels im firing thru GTM:
    Inline image 3

    It would be great if you can guide me how to solve these issues.

    Thanks,
    Evyatar

  • Sajid

    Hello Evyatar Sagie :slight_smile:

    1. i've set the super smush feature but i still get this alert in google speed test:
    Inline image 1

    I can see that you or your theme does have full images embedded on your website.

    First it is always great to create thumbnails of a specific sizes to avoid loading of full images.

    It definitely require coding, so if you can ping developer of theme then ask him to replace full images with thumbnails.

    In case, you can't then please you have to smush original/full images too. To enable smushing original images, go to Media -> WP Smush -> Resize original images and toggle the button.

    From here, you can optionally set the maximum size of images that definitely will help you increase the site performance.

    2. i get this one as well -
    Inline image 2

    It appears that you are using Autoptimize plugin too for minification. Instead, I would suggest you to use Hummingbird built in Minification module.

    3. i get this alert on the pixels im firing thru GTM:
    Inline image 3

    It appears that you have not enabled Browser Caching. This tells browser, save the content for later used instead of loading them from internet again and again.

    You can enable this feature from Hummingbird -> Browser Caching.

    After enabling, if you don't know what you should set for expiry then stick with the recommended values.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.