I've had this plugin working perfectly for a while and all

I've had this plugin working perfectly for a while and all of a sudden it has stopped working. I use this to show a Constant Contact form and I did update that plugin, but it doesn't appear to be the issue to me. It looks like the plugin is throwing a 500 error on page load when trying to call back to the AJAX. It's odd because the request headers show some URLs backwards, is it supposed to do that? Also you can see from the response that it starts kicking out code and never finishes. Here's what Chrome's inspector is showing.

HEADERS:

Remote Address:64.150.188.32:80
Request URL:http://projects.neuralinteractive.com/VnS/tf/wp-admin/admin-ajax.php?callback=po_data&orig_request_uri=%2FVnS%2Ftf%2Fcommunity-grants%2F&action=inc_popup&do=get_data&thefrom=%2Fstnarg-ytinummoc%2Fft%2FSnV%2Fmoc.evitcaretnilaruen.stcejorp%2F%2F%3Aptth&thereferrer=%2Fstcaf-kciuq%2Fft%2FSnV%2Fmoc.evitcaretnilaruen.stcejorp%2F%2F%3Aptth&_=1418842205692
Request Method:GET
Status Code:500 Internal Server Error
Request Headersview source
Accept:text/javascript, application/javascript, application/ecmascript, application/x-ecmascript, */*; q=0.01
Accept-Encoding:gzip, deflate, sdch
Accept-Language:en-US,en;q=0.8
Cache-Control:no-cache
Connection:keep-alive
Cookie:wordpress_c39d4c7dde8d14c6521f548b11bb970f=admin%7C1418949650%7CSf8vUFKng7F7QoKr4dhYu11hEruNdzf4x0QsVF7LZAK%7Ce1016823d8af7dad3aadafe724296651211006fa3b8131411f31f407b2886ce7; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_c39d4c7dde8d14c6521f548b11bb970f=admin%7C1418949650%7CSf8vUFKng7F7QoKr4dhYu11hEruNdzf4x0QsVF7LZAK%7C38efed831f732f84ca363dcfe4d43da78195f712fb7e463d6acc817b636415d2; wp-settings-1=libraryContent%3Dbrowse%26editor%3Dtinymce%26hidetb%3D1; wp-settings-time-1=1418781961; __utma=224051588.1049988541.1416356889.1416356889.1416524082.2; __utmz=224051588.1416356889.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); __utma=29090045.322310922.1411517548.1416959073.1417022124.23; __utmz=29090045.1411517548.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); PHPSESSID=okbt1vsf7dggj6i28pq365cbp5; __unam=24c4c6e-14838f41cdf-49f06d3e-75
Host:projects.neuralinteractive.com
Pragma:no-cache
Referer:http://projects.neuralinteractive.com/VnS/tf/community-grants/
User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36
X-Requested-With:XMLHttpRequest
Query String Parametersview sourceview URL encoded
callback:po_data
orig_request_uri:disappointed:VnS/tf/community-grants/
action:inc_popup
do:get_data
thefrom:disappointed:stnarg-ytinummoc/ft/SnV/moc.evitcaretnilaruen.stcejorp//:ptth
thereferrer:disappointed:stcaf-kciuq/ft/SnV/moc.evitcaretnilaruen.stcejorp//:ptth
_:1418842205692
Response Headersview source
Cache-Control:no-cache, must-revalidate, max-age=0
Content-Length:478
Content-Type:text/html; charset=UTF-8
Date:Wed, 17 Dec 2014 18:50:21 GMT
Expires:Wed, 11 Jan 1984 05:00:00 GMT
Pragma:no-cache
Server:Microsoft-IIS/7.5
X-Content-Type-Options:nosniff
X-Frame-Options:SAMEORIGIN
X-Powered-By:ASP.NET
X-Powered-By:stuck_out_tongue:HP/5.4.0
X-Robots-Tag:noindex

RESPONSE:

<div id="a4fec751c58851e7b99803befc6920225"
class="style-minimal wdpu-container wdpu-background no-img rounded wdpu-170 "
style="display: none;">

<div class="wdpu-msg resize move no-move-x " style="">
<a href="#"
class="wdpu-close no-title"
title="Close this box">

<div class="wdpu-msg-inner resize">

<div class="wdpu-middle">

<div class="wdpu-text">
<div class="wdpu-inner no-bm">
<div class="wdpu-content">

We're supposed to show the client this functionality today so I'd appreciate any help I can get. Thanks!