I've just installed Ultimate Facebook, following the video

Hi,

I've just installed Ultimate Facebook, following the video tutorial (including the updated one).

I created a Facebook app and copy/pasted it in the plugin settings.

Unfortunately, I have the famous : "Please, enter correct Facebook API settings and make sure Facebook app is public".

I read a lot about it in the forum :
- I am sure it is "public"
- I checked, rechecked and rerechecked the keys : they are correct (no space at the end, etc.)
- I disabled all my plugins one by one
A real strange thing occured :
There were only 3 or 4 active plugins left, and the error message disappeared !
I reactivated it, the error message came back : I thought I had found the conflictual plugin...
I de-activated it once more and... still the error message.
No way to make it go.

I reactivated every plugin.
For the tenth time, I rechecked the keys, saved and... Green !
Waouh.
I touched nothing, resaved and... Red !
OMG.

I tried to use a different browser => same pb.
I specified my locale Settings => same pb
I tried to reset secret key => same pb.
I created another app => same pb.

Now I'm getting bored and frustrated.

Any idea ?
Thx.

Just 1 second ago, I clicked on the plugin settings; it was ok and I could navigate on the others tabs (permissions&tokens, facebook connect...).
BUT after saving changes to another tab, I could not navigate any more between the tabs. The plugin must have been desynchronised with facebook.
I clciked again on Facebook Settings and... Error.
Grrrrr.