Defender

I've tried to activate Defender plugin twice, and I've always destroyed the site, and I had to recover the entire site from the backup because deleting the plugin itself did not help. Do you have any advice?

  • James Morris

    Hello Kuczys

    I hope you are well today.

    This is a very strange report. Normally deactivating and removing a plugin should not affect any other part of the site unless there's custom code hooks that are tied into that plugin. Which, with Defender, there's no such hooks.

    Could you tell me a bit more about how the site is breaking? Are you getting a white screen? Are you getting error messages on screen?

    Could you please make a full backup of your site, enable WP_DEBUG and then try removing Defender again.

    uld you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've deactivated/removed Defender, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, open that file with a text editor like notepad (Windows), GEdit (Linux), or TextEdit (Mac). You can then save the file as a .txt file and upload it here as an attachment to your post.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.