Jetpack could not connected to WordPress.com

Hello,

I have JetPack Plugin and activate it for my own use only. But,
I've got this message when try to connect to WordPress.com:

Error Details: The Jetpack server could not communicate with your site's XML-RPC URL. Please check to make sure http://bisneshost.my/xmlrpc.php is working properly. It should show 'XML?RPC server accepts POST requests only.' on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.

Are some of you who have experienced it and know how to solve it?

  • Mohd Najib
    • Site Builder, Child of Zeus

    @Manuel

    I've tried it several times. I also find a variety of solutions. All show the same direction. I attach a message from Jetpack Debugging Center:

    It looks like your site can not communicate properly with Jetpack.

    ==============================================================
    SELF:
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Thu, 29 Aug 2013 13:42:25 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => {"error":"XML-RPC is not responding correctly ( 200 )","error_description":"It looks like XML-RPC is not responding correctly. Please make sure XML-RPC is turned on for your site and is set up to respond to all content types. You can test this yourself by running the following command from the command line:

    curl -d '<methodCall><methodName>demo.sayHello<\/methodName><\/methodCall>' https:\/\/bisneshost.my\/xmlrpc.php<\/code><\/blockquote><p>The answer should be:<\/p>

    <?xml version="1.0" encoding="UTF-8"?>\n<methodResponse>\n  <params>\n    <param>\n      <value>\n      <string>Hello!<\/string>\n      <\/value>\n    <\/param>\n  <\/params>\n<\/methodResponse><\/pre><\/code><\/blockquote>"}
        [response] => Array
            (
                [code] => 400
                [message] => Bad Request
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )
    ==============================================================
    
    Hope you can help.

  • Mohd Najib
    • Site Builder, Child of Zeus

    @Jack Kitterhing

    I have attached the debug for your reference:

    ----------------------------------------------

    DEBUG INFO:
    jQuery version: 1.10.2

    CLIENT_ID:
    BLOG_TOKEN:
    MASTER_USER:
    CERT: 0
    TIME_DIFF: 3
    VERSION: 2.3.5:1377776089
    OLD_VERSION: 2.3.5:1377776089
    PUBLIC:
    USER_ID: 1
    USER_TOKEN: [this user has no token]
    PHP_VERSION: 5.3.24
    WORDPRESS_VERSION: 3.6
    JETPACK__VERSION: 2.3.5
    JETPACK__PLUGIN_DIR: /home/bisnes/public_html/wp-content/plugins/jetpack/
    SITE_URL: http://bisneshost.my
    HOME_URL: http://bisneshost.my

    TEST RESULTS:

    HTTP: PASS
    HTTPS: PASS
    SELF: FAIL

    RAW TEST RESULTS:

    HTTP
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Thu, 29 Aug 2013 13:30:02 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [vary] => Cookie
    [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => OK
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    HTTPS
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Thu, 29 Aug 2013 13:30:03 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [vary] => Cookie
    [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => OK
    [response] => Array
    (
    [code] => 200
    [message] => OK
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

    SELF
    Array
    (
    [headers] => Array
    (
    [server] => nginx
    [date] => Thu, 29 Aug 2013 13:30:13 GMT
    [content-type] => text/plain;charset=utf-8
    [connection] => close
    [x-pingback] => http://jetpack.wordpress.com/xmlrpc.php
    [expires] => Wed, 11 Jan 1984 05:00:00 GMT
    [cache-control] => no-cache, must-revalidate, max-age=60
    [pragma] => no-cache
    [x-hacker] => Jetpack Test
    )

    [body] => {"error":"XML-RPC is not responding correctly ( 200 )","error_description":"It looks like XML-RPC is not responding correctly. Please make sure XML-RPC is turned on for your site and is set up to respond to all content types. You can test this yourself by running the following command from the command line:

    curl -d '<methodCall><methodName>demo.sayHello</methodName></methodCall>' https://bisneshost.my/xmlrpc.php
    <p>The answer should be:</p>

    <?xml version="1.0" encoding="UTF-8"?>n<methodResponse>n  <params>n    <param>n      <value>n      <string>Hello!</string>n      </value>n    </param>n  </params>n</methodResponse>
    "}
    [response] => Array
    (
    [code] => 400
    [message] => Bad Request
    )

    [cookies] => Array
    (
    )

    [filename] =>
    )

  • Mohd Najib
    • Site Builder, Child of Zeus

    @Jack Kitterhing

    I've told this to my hosting provider. And this was their feedback:

    =================================================================
    Dear Sir,

    ini_set function is disabled for security reason, as mentioned in the error message.
    You may try to edit the file stated in the error message and comment out or add an "@" in front of ini_set at line 278.

    Please do not hesitate to contact us if we can be of further assistance. Thank you!
    =================================================================

    Does this help?

  • Mohd Najib
    • Site Builder, Child of Zeus

    Hello @Jack Kitterhing

    I have forwarded this issue to my hosting provider. For your information, they have a specific reason to disabled ini_set () for Security Reasons. Therefore, they have a simple solution to me. Allow me to share it here so that you can make it as a reference or for future improvements.

    1) My problem started when I could not connect my WordPress site with WordPress.com.

    2) Jetpack gives the message that explains why my WordPress sites are not able to connect with WordPress.com.

    The message is:

    Error Details: The Jetpack server could not communicate with your site's XML-RPC URL. Please check to make sure http://bisneshost.my/xmlrpc.php is working properly. It should show 'XML?RPC server accepts POST requests only.' on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.

    3) I have tested the url specified and it displays a few lines. I can not specify here because I forgot to write it.

    4) I open the specified file, which is / public_html / wp-includes / load.php /. I see the line 278 as shown. I find this line: ini_set( 'display_errors', 0 );

    5) I changed the line to: @ini_set( 'display_errors', 0 );

    6) I tried to reconnect my WordPress site with WordPress.com, and boom! It was successful! A miracle!

    You know, it solves the problem! So, it is not caused by the plugin, theme or wp-config. I have made a variety of ways to overcome this problem including reinstalling everything. lol, crazy work right? I was also scolded by my clients, because they affect their website! However, it is worth it. That's why I have to share it with you and others. It's pretty simple really! lol, it has made me crazy.

    You want to know something? I have to say thank you for your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.